Debian: DSA-2154-1: exim4 security update

    Date30 Jan 2011
    CategoryDebian
    351
    Posted ByLinuxSecurity Advisories
    A design flaw (CVE-2010-4345) in exim4 allowed the loal Debian-exim user to obtain root privileges by specifying an alternate configuration file using the -C option or by using the macro override facility (-D option). Unfortunately, fixing this vulnerability is not
    
    - ------------------------------------------------------------------------
    Debian Security Advisory DSA-2154-1                  This email address is being protected from spambots. You need JavaScript enabled to view it.
    http://www.debian.org/security/                           Stefan Fritsch
    January 30, 2011                      http://www.debian.org/security/faq
    - ------------------------------------------------------------------------
    
    Package          : exim4
    Vulnerability    : privilege escalation
    Problem type     : local
    CVE Id(s)        : CVE-2010-4345 CVE-2011-0017
    Behaviour change : yes
    
    A design flaw (CVE-2010-4345) in exim4 allowed the loal Debian-exim
    user to obtain root privileges by specifying an alternate
    configuration file using the -C option or by using the macro override
    facility (-D option).  Unfortunately, fixing this vulnerability is not
    possible without some changes in exim4's behvaviour. If you use the -C
    or -D options or use the system filter facility, you should evaluate
    the changes carefully and adjust your configuration accordingly. The
    Debian default configuration is not affected by the changes.
    
    The detailed list of changes is described in the NEWS.Debian file in
    the packages. The relevant sections are also reproduced below.
    
    In addition to that, missing error handling for the setuid/setgid
    system calls allowed the Debian-exim user to cause root to append
    log data to arbitrary files (CVE-2011-0017).
    
    For the stable distribution (lenny), these problems have been fixed in
    version 4.69-9+lenny3.
    
    For the testing distribution (squeeze) and the unstable distribution
    (sid), these problem have been fixed in version 4.72-4.
    
    Further information about Debian Security Advisories, how to apply
    these updates to your system and frequently asked questions can be
    found at: http://www.debian.org/security/
    
    - ------------------------------------------------------------------------
    Excerpt from the NEWS.Debian file from the packages exim4-daemon-light
    and exim4-daemon-heavy:
    
    Exim versions up to and including 4.72 are vulnerable to
    CVE-2010-4345. This is a privilege escalation issue that allows the
    exim user to gain root privileges by specifying an alternate
    configuration file using the -C option. The macro override facility
    (-D) might also be misused for this purpose.
    
    In reaction to this security vulnerability upstream has made a number
    of user visible changes. This package includes these changes.
    
    If exim is invoked with the -C or -D option the daemon will not regain
    root privileges though re-execution. This is usually necessary for
    local delivery, though. Therefore it is generally not possible anymore
    to run an exim daemon with -D or -C options.
    
    However this version of exim has been built with
    TRUSTED_CONFIG_LIST=/etc/exim4/trusted_configs. TRUSTED_CONFIG_LIST
    defines a list of configuration files which are trusted; if a config
    file is owned by root and matches a pathname in the list, then it may
    be invoked by the Exim build-time user without Exim relinquishing root
    privileges.
    
    As a hotfix to not break existing installations of mailscanner we have
    also set WHITELIST_D_MACROS=OUTGOING. i.e. it is still possible to
    start exim with -DOUTGOING while being able to do local deliveries.
    
    If you previously were using -D switches you will need to change your
    setup to use a separate configuration file. The ".include" mechanism
    makes this easy.
    
    The system filter is run as exim_user instead of root by default.  If
    your setup requies root privileges when running the system filter you
    will need to set the system_filter_user exim main configuration
    option.
    - ------------------------------------------------------------------------
    
    Mailing list: This email address is being protected from spambots. You need JavaScript enabled to view it.
    
    
    You are not authorised to post comments.

    Comments powered by CComment

    Advisories

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"64","type":"x","order":"1","pct":57.14,"resources":[]},{"id":"88","title":"Should be more technical","votes":"15","type":"x","order":"2","pct":13.39,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"33","type":"x","order":"3","pct":29.46,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.