- -------------------------------------------------------------------------
Debian Security Advisory DSA-5023-1                   [email protected]
https://www.debian.org/security/                     Salvatore Bonaccorso
December 18, 2021                     https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : modsecurity-apache
CVE ID         : CVE-2021-42717

It was discovered that modsecurity-apache, an Apache module to tighten
the Web application security, does not properly handles excessively
nested JSON objects, which could result in denial of service. The update
introduces a new 'SecRequestBodyJsonDepthLimit' option to limit the
maximum request body JSON parsing depth which ModSecurity will accept
(defaults to 10000).

For the oldstable distribution (buster), this problem has been fixed
in version 2.9.3-1+deb10u1.

For the stable distribution (bullseye), this problem has been fixed in
version 2.9.3-3+deb11u1.

We recommend that you upgrade your modsecurity-apache packages.

For the detailed security status of modsecurity-apache please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/modsecurity-apache

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: d[email protected]