Debian: DSA-5085-2: expat regression update | LinuxSecurity.com

- -------------------------------------------------------------------------
Debian Security Advisory DSA-5085-2                   [email protected]
https://www.debian.org/security/                     Salvatore Bonaccorso
March 13, 2022                        https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : expat

The update for expat released as DSA 5085-1 introduced regressions for
applications using URI characters (':' in particular) for a namespace
separator (while the HTML API docs of function XML_ParserCreateNS have
been advising against their use). Updated expat packages are now
available which relax the fix for CVE-2022-25236 with regard to RFC 3986
URI characters.

For the oldstable distribution (buster), this problem has been fixed
in version 2.2.6-2+deb10u4.

For the stable distribution (bullseye), this problem has been fixed in
version 2.2.10-2+deb11u3.

We recommend that you upgrade your expat packages.

For the detailed security status of expat please refer to its security
tracker page at:
https://security-tracker.debian.org/tracker/expat

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Debian: DSA-5085-2: expat regression update

March 13, 2022
The update for expat released as DSA 5085-1 introduced regressions for applications using URI characters (':' in particular) for a namespace separator (while the HTML API docs of f...

Summary

For the oldstable distribution (buster), this problem has been fixed
in version 2.2.6-2+deb10u4.

For the stable distribution (bullseye), this problem has been fixed in
version 2.2.10-2+deb11u3.

We recommend that you upgrade your expat packages.

For the detailed security status of expat please refer to its security
tracker page at:
https://security-tracker.debian.org/tracker/expat

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Severity
The update for expat released as DSA 5085-1 introduced regressions for
applications using URI characters (':' in particular) for a namespace
separator (while the HTML API docs of function XML_ParserCreateNS have
been advising against their use). Updated expat packages are now
available which relax the fix for CVE-2022-25236 with regard to RFC 3986
URI characters.

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.