Debian: DSA-5115-1: webkit2gtk security update | LinuxSecurity.com
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

- -------------------------------------------------------------------------
Debian Security Advisory DSA-5115-1                   [email protected]
https://www.debian.org/security/                           Alberto Garcia
April 08, 2022                        https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : webkit2gtk
CVE ID         : CVE-2022-22624 CVE-2022-22628 CVE-2022-22629

The following vulnerabilities have been discovered in the WebKitGTK
web engine:

CVE-2022-22624

    Kirin discovered that processing maliciously crafted web content
    may lead to arbitrary code execution.

CVE-2022-22628

    Kirin discovered that Processing maliciously crafted web content
    may lead to arbitrary code execution.

CVE-2022-22629

    Jeonghoon Shin discovered that processing maliciously crafted web
    content may lead to arbitrary code execution.

For the oldstable distribution (buster), these problems have been fixed
in version 2.36.0-3~deb10u1.

For the stable distribution (bullseye), these problems have been fixed in
version 2.36.0-3~deb11u1.

We recommend that you upgrade your webkit2gtk packages.

For the detailed security status of webkit2gtk please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/webkit2gtk

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Debian: DSA-5115-1: webkit2gtk security update

April 8, 2022

Summary

The following vulnerabilities have been discovered in the WebKitGTK
web engine:

CVE-2022-22624

Kirin discovered that processing maliciously crafted web content
may lead to arbitrary code execution.

CVE-2022-22628

Kirin discovered that Processing maliciously crafted web content
may lead to arbitrary code execution.

CVE-2022-22629

Jeonghoon Shin discovered that processing maliciously crafted web
content may lead to arbitrary code execution.

For the oldstable distribution (buster), these problems have been fixed
in version 2.36.0-3~deb10u1.

For the stable distribution (bullseye), these problems have been fixed in
version 2.36.0-3~deb11u1.

We recommend that you upgrade your webkit2gtk packages.

For the detailed security status of webkit2gtk please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/webkit2gtk

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Severity
Package : webkit2gtk
CVE ID : CVE-2022-22624 CVE-2022-22628 CVE-2022-22629

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.