Debian: DSA-5138-1: waitress security update | LinuxSecurity.com

Advisories

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-5138-1                   [email protected]
https://www.debian.org/security/                       Moritz Muehlenhoff
May 17, 2022                          https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : waitress
CVE ID         : CVE-2022-24761
Debian Bug     : 1008013

It was discovered that the Waitress WSGI server was susceptible to
HTTP request smuggling in some scenarios when used behind a proxy.

For the oldstable distribution (buster), this problem has been fixed
in version 1.2.0~b2-2+deb10u1.

For the stable distribution (bullseye), this problem has been fixed in
version 1.4.4-1.1+deb11u1.

We recommend that you upgrade your waitress packages.

For the detailed security status of waitress please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/waitress

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Debian: DSA-5138-1: waitress security update

May 17, 2022
It was discovered that the Waitress WSGI server was susceptible to HTTP request smuggling in some scenarios when used behind a proxy

Summary

It was discovered that the Waitress WSGI server was susceptible to
HTTP request smuggling in some scenarios when used behind a proxy.

For the oldstable distribution (buster), this problem has been fixed
in version 1.2.0~b2-2+deb10u1.

For the stable distribution (bullseye), this problem has been fixed in
version 1.4.4-1.1+deb11u1.

We recommend that you upgrade your waitress packages.

For the detailed security status of waitress please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/waitress

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Severity
Package : waitress
CVE ID : CVE-2022-24761
Debian Bug : 1008013

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.