Debian: DSA-5229-1: freecad security update | LinuxSecurity.com
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-5229-1                   [email protected]
https://www.debian.org/security/                                  Aron Xu
September 13, 2022                    https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : freecad
CVE ID         : CVE-2021-45844 CVE-2021-45845

Two vulnerabilities were discovered in FreeCAD, a CAD/CAM program,
which could result in the execution of arbitrary shell commands when
opening a malformed file.

For the stable distribution (bullseye), these problems have been fixed in
version 0.19.1+dfsg1-2+deb11u1.

We recommend that you upgrade your freecad packages.

For the detailed security status of freecad please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/freecad

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Debian: DSA-5229-1: freecad security update

September 13, 2022
Two vulnerabilities were discovered in FreeCAD, a CAD/CAM program, which could result in the execution of arbitrary shell commands when opening a malformed file

Summary

Two vulnerabilities were discovered in FreeCAD, a CAD/CAM program,
which could result in the execution of arbitrary shell commands when
opening a malformed file.

For the stable distribution (bullseye), these problems have been fixed in
version 0.19.1+dfsg1-2+deb11u1.

We recommend that you upgrade your freecad packages.

For the detailed security status of freecad please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/freecad

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Severity
Package : freecad
CVE ID : CVE-2021-45844 CVE-2021-45845

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.