Debian: DSA-5274-1: wpewebkit security update | LinuxSecurity.com
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

- -------------------------------------------------------------------------
Debian Security Advisory DSA-5274-1                   [email protected]
https://www.debian.org/security/                           Alberto Garcia
November 08, 2022                     https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : wpewebkit
CVE ID         : CVE-2022-42799 CVE-2022-42823 CVE-2022-42824

The following vulnerabilities have been discovered in the WPE WebKit
web engine:

CVE-2022-42799

    Jihwan Kim and Dohyun Lee discovered that visiting a malicious
    website may lead to user interface spoofing.

CVE-2022-42823

    Dohyun Lee discovered that processing maliciously crafted web
    content may lead to arbitrary code execution.

CVE-2022-42824

    Abdulrahman Alqabandi, Ryan Shin and Dohyun Lee discovered that
    processing maliciously crafted web content may disclose sensitive
    user information.

For the stable distribution (bullseye), these problems have been fixed in
version 2.38.2-1~deb11u1.

We recommend that you upgrade your wpewebkit packages.

For the detailed security status of wpewebkit please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/wpewebkit

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Debian: DSA-5274-1: wpewebkit security update

November 8, 2022

Summary

The following vulnerabilities have been discovered in the WPE WebKit
web engine:

CVE-2022-42799

Jihwan Kim and Dohyun Lee discovered that visiting a malicious
website may lead to user interface spoofing.

CVE-2022-42823

Dohyun Lee discovered that processing maliciously crafted web
content may lead to arbitrary code execution.

CVE-2022-42824

Abdulrahman Alqabandi, Ryan Shin and Dohyun Lee discovered that
processing maliciously crafted web content may disclose sensitive
user information.

For the stable distribution (bullseye), these problems have been fixed in
version 2.38.2-1~deb11u1.

We recommend that you upgrade your wpewebkit packages.

For the detailed security status of wpewebkit please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/wpewebkit

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Severity
Package : wpewebkit
CVE ID : CVE-2022-42799 CVE-2022-42823 CVE-2022-42824

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.