Debian: DSA-5307-1: libcommons-net-java security update | LinuxSecu...
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-5307-1                   [email protected]
https://www.debian.org/security/                          Markus Koschany
December 29, 2022                     https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : libcommons-net-java
CVE ID         : CVE-2021-37533
Debian Bug     : 1025910

ZeddYu Lu discovered that the FTP client of Apache Commons Net, a Java
client API for basic Internet protocols, trusts the host from PASV response
by default. A malicious server can redirect the Commons Net code to use a
different host, but the user has to connect to the malicious server in the
first place. This may lead to leakage of information about services running
on the private network of the client.

For the stable distribution (bullseye), this problem has been fixed in
version 3.6-1+deb11u1.

We recommend that you upgrade your libcommons-net-java packages.

For the detailed security status of libcommons-net-java please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libcommons-net-java

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Debian: DSA-5307-1: libcommons-net-java security update

December 29, 2022
ZeddYu Lu discovered that the FTP client of Apache Commons Net, a Java client API for basic Internet protocols, trusts the host from PASV response by default

Summary

ZeddYu Lu discovered that the FTP client of Apache Commons Net, a Java
client API for basic Internet protocols, trusts the host from PASV response
by default. A malicious server can redirect the Commons Net code to use a
different host, but the user has to connect to the malicious server in the
first place. This may lead to leakage of information about services running
on the private network of the client.

For the stable distribution (bullseye), this problem has been fixed in
version 3.6-1+deb11u1.

We recommend that you upgrade your libcommons-net-java packages.

For the detailed security status of libcommons-net-java please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libcommons-net-java

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Severity
Package : libcommons-net-java
CVE ID : CVE-2021-37533
Debian Bug : 1025910

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.