Debian: DSA-5312-1: libjettison-java security update | LinuxSecurit...
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-5312-1                   [email protected]
https://www.debian.org/security/                          Markus Koschany
January 11, 2023                      https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : libjettison-java
CVE ID         : CVE-2022-40149 CVE-2022-40150 CVE-2022-45685 CVE-2022-45693
Debian Bug     : 1022553 1022554

Several flaws have been discovered in libjettison-java, a collection of StAX
parsers and writers for JSON. Specially crafted user input may cause a denial
of service via out-of-memory or stack overflow errors.

For the stable distribution (bullseye), these problems have been fixed in
version 1.5.3-1~deb11u1.

We recommend that you upgrade your libjettison-java packages.

For the detailed security status of libjettison-java please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libjettison-java

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Debian: DSA-5312-1: libjettison-java security update

January 10, 2023
Several flaws have been discovered in libjettison-java, a collection of StAX parsers and writers for JSON

Summary

Several flaws have been discovered in libjettison-java, a collection of StAX
parsers and writers for JSON. Specially crafted user input may cause a denial
of service via out-of-memory or stack overflow errors.

For the stable distribution (bullseye), these problems have been fixed in
version 1.5.3-1~deb11u1.

We recommend that you upgrade your libjettison-java packages.

For the detailed security status of libjettison-java please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libjettison-java

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: [email protected]

Severity
Package : libjettison-java
CVE ID : CVE-2022-40149 CVE-2022-40150 CVE-2022-45685 CVE-2022-45693
Debian Bug : 1022553 1022554

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.