-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA512

- -------------------------------------------------------------------------
Debian Security Advisory DSA-5409-1                   security@debian.org
https://www.debian.org/security/                       Moritz Muehlenhoff
May 23, 2023                          https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : libssh
CVE ID         : CVE-2023-1667 CVE-2023-2283
Debian Bug     : 1035832

Two security issues have been discovered in libssh, a tiny C SSH library:

CVE-2023-1667

    Philip Turnbull discovered a NULL pointer dereference which could
    result in denial of service.

CVE-2023-2283

    Kevin Backhouse discovered that pki_verify_data_signature() may
    fail to correctly validate authentication in memory pressure
    situations.

For the stable distribution (bullseye), these problems have been fixed in
version 0.9.7-0+deb11u1.

We recommend that you upgrade your libssh packages.

For the detailed security status of libssh please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/libssh

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org

Debian: DSA-5409-1: libssh security update

May 23, 2023
Two security issues have been discovered in libssh, a tiny C SSH library: CVE-2023-1667

Summary

Two security issues have been discovered in libssh, a tiny C SSH library:

CVE-2023-1667

Philip Turnbull discovered a NULL pointer dereference which could
result in denial of service.

CVE-2023-2283

Kevin Backhouse discovered that pki_verify_data_signature() may
fail to correctly validate authentication in memory pressure
situations.

For the stable distribution (bullseye), these problems have been fixed in
version 0.9.7-0+deb11u1.

We recommend that you upgrade your libssh packages.

For the detailed security status of libssh please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/source-package/libssh

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org

Severity
Package : libssh
CVE ID : CVE-2023-1667 CVE-2023-2283

Related News