- -------------------------------------------------------------------------
Debian Security Advisory DSA-5470-1                   security@debian.org
https://www.debian.org/security/                     Salvatore Bonaccorso
August 06, 2023                       https://www.debian.org/security/faq
- -------------------------------------------------------------------------

Package        : python-werkzeug
CVE ID         : CVE-2023-23934 CVE-2023-25577
Debian Bug     : 1031370

Several vulnerabilities were discovered in python-werkzeug, a collection
of utilities for WSGI applications.

CVE-2023-23934

    It was discovered that Werkzeug did not properly handle the parsing
    of nameless cookies which may allow shadowing of other cookies.

CVE-2023-25577

    It was discovered that Werkzeug could parse unlimited number of
    parts, including file parts, which may result in denial of service.

For the oldstable distribution (bullseye), these problems have been fixed
in version 1.0.1+dfsg1-2+deb11u1.

We recommend that you upgrade your python-werkzeug packages.

For the detailed security status of python-werkzeug please refer to its
security tracker page at:
https://security-tracker.debian.org/tracker/source-package/python-werkzeug

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org

Debian: DSA-5470-1: python-werkzeug security update

August 6, 2023
Several vulnerabilities were discovered in python-werkzeug, a collection of utilities for WSGI applications

Summary

CVE-2023-23934

It was discovered that Werkzeug did not properly handle the parsing
of nameless cookies which may allow shadowing of other cookies.

CVE-2023-25577

It was discovered that Werkzeug could parse unlimited number of
parts, including file parts, which may result in denial of service.

For the oldstable distribution (bullseye), these problems have been fixed
in version 1.0.1+dfsg1-2+deb11u1.

We recommend that you upgrade your python-werkzeug packages.

For the detailed security status of python-werkzeug please refer to its
security tracker page at:
https://security-tracker.debian.org/tracker/source-package/python-werkzeug

Further information about Debian Security Advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://www.debian.org/security/

Mailing list: debian-security-announce@lists.debian.org

Severity
Package : python-werkzeug
CVE ID : CVE-2023-23934 CVE-2023-25577

Related News