- -------------------------------------------------------------------------
Debian LTS Advisory DLA-2786-1                [email protected]
https://www.debian.org/lts/security/                         Anton Gladky
October 16, 2021                              https://wiki.debian.org/LTS
- -------------------------------------------------------------------------

Package        : nghttp2
Version        : 1.18.1-1+deb9u2
CVE ID         : CVE-2018-1000168 CVE-2020-11080

Two security issue have been discovered in nghttp2: server, proxy and client
implementing HTTP/2.

CVE-2018-1000168

    An Improper Input Validation CWE-20 vulnerability found in ALTSVC frame handling
    that can result in segmentation fault leading to denial of service. This attack
    appears to be exploitable via network client.

CVE-2020-11080

    The overly large HTTP/2 SETTINGS frame payload causes denial of service.
    The proof of concept attack involves a malicious client constructing a SETTINGS
    frame with a length of 14,400 bytes (2400 individual settings entries) over and over again.
    The attack causes the CPU to spike at 100%.

For Debian 9 stretch, these problems have been fixed in version
1.18.1-1+deb9u2.

We recommend that you upgrade your nghttp2 packages.

For the detailed security status of nghttp2 please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/nghttp2

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS