Debian LTS: DLA-3062-1: ublock-origin security update | LinuxSecuri...

Advisories

-------------------------------------------------------------------------
Debian LTS Advisory DLA-3062-1                [email protected]
https://www.debian.org/lts/security/                      Markus Koschany
June 29, 2022                                 https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package        : ublock-origin
Version        : 1.42.0+dfsg-1~deb9u1
CVE ID         : CVE-2021-36773
Debian Bug     : 991386

uBlock, a Firefox add-on and efficient ads, malware and trackers blocker,
supported an arbitrary depth of parameter nesting for strict blocking, which
allows crafted web sites to cause a denial of service (unbounded recursion that
can trigger memory consumption and a loss of all blocking functionality).

Please note that webext-ublock-origin was replaced by webext-ublock-origin-
firefox.

For Debian 9 stretch, this problem has been fixed in version
1.42.0+dfsg-1~deb9u1.

We recommend that you upgrade your ublock-origin packages.

For the detailed security status of ublock-origin please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/ublock-origin

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3062-1: ublock-origin security update

June 29, 2022
uBlock, a Firefox add-on and efficient ads, malware and trackers blocker, supported an arbitrary depth of parameter nesting for strict blocking, which allows crafted web sites to c...

Summary


uBlock, a Firefox add-on and efficient ads, malware and trackers blocker,
supported an arbitrary depth of parameter nesting for strict blocking, which
allows crafted web sites to cause a denial of service (unbounded recursion that
can trigger memory consumption and a loss of all blocking functionality).

Please note that webext-ublock-origin was replaced by webext-ublock-origin-
firefox.

For Debian 9 stretch, this problem has been fixed in version
1.42.0+dfsg-1~deb9u1.

We recommend that you upgrade your ublock-origin packages.

For the detailed security status of ublock-origin please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/ublock-origin

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Severity
Package : ublock-origin
Version : 1.42.0+dfsg-1~deb9u1
CVE ID : CVE-2021-36773
Debian Bug : 991386