Debian LTS: DLA-3098-1: libmodbus security update | LinuxSecurity.com
-------------------------------------------------------------------------
Debian LTS Advisory DLA-3098-1                [email protected]
https://www.debian.org/lts/security/                      Markus Koschany
September 04, 2022                            https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package        : libmodbus
Version        : 3.1.4-2+deb10u2
CVE ID         : CVE-2022-0367

A heap-based buffer overflow flaw was found in libmodbus, a library for the
Modbus protocol, which can be abused for a denial of service attack or
memory corruption.

For Debian 10 buster, this problem has been fixed in version
3.1.4-2+deb10u2.

We recommend that you upgrade your libmodbus packages.

For the detailed security status of libmodbus please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libmodbus

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3098-1: libmodbus security update

September 4, 2022
A heap-based buffer overflow flaw was found in libmodbus, a library for the Modbus protocol, which can be abused for a denial of service attack or memory corruption

Summary

Severity
Package : libmodbus
Version : 3.1.4-2+deb10u2
CVE ID : CVE-2022-0367

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.