Debian LTS: DLA-3284-1: libapache-session-ldap-perl security update...
-------------------------------------------------------------------------
Debian LTS Advisory DLA-3284-1                [email protected]
https://www.debian.org/lts/security/                       Guilhem Moulin
January 28, 2023                              https://wiki.debian.org/LTS
-------------------------------------------------------------------------

Package        : libapache-session-ldap-perl
Version        : 0.4-1+deb10u1
CVE ID         : CVE-2020-36658

In Apache::Session::LDAP before 0.5, validity of the X.509 certificate
is not checked by default when connecting to remote LDAP backends,
because the default configuration of the Net::LDAPS module for Perl is
used.

This update changes the default behavior to require X.509 validation
against the distribution bundle /etc/ssl/certs/ca-certificates.crt.
Previous behavior can reverted by setting `ldapVerify => "none"` when
initializing the Apache::Session::LDAP object.

NOTE: this update is a prerequisite for LemonLDAP::NG's CVE-2020-16093
fix when its session backend is set to Apache::Session::LDAP.

For Debian 10 buster, this problem has been fixed in version
0.4-1+deb10u1.

We recommend that you upgrade your libapache-session-ldap-perl packages.

For the detailed security status of libapache-session-ldap-perl please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libapache-session-ldap-perl

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS

Debian LTS: DLA-3284-1: libapache-session-ldap-perl security update

January 28, 2023
In Apache::Session::LDAP before 0.5, validity of the X.509 certificate is not checked by default when connecting to remote LDAP backends, because the default configuration of the N...

Summary

This update changes the default behavior to require X.509 validation
against the distribution bundle /etc/ssl/certs/ca-certificates.crt.
Previous behavior can reverted by setting `ldapVerify => "none"` when
initializing the Apache::Session::LDAP object.

NOTE: this update is a prerequisite for LemonLDAP::NG's CVE-2020-16093
fix when its session backend is set to Apache::Session::LDAP.

For Debian 10 buster, this problem has been fixed in version
0.4-1+deb10u1.

We recommend that you upgrade your libapache-session-ldap-perl packages.

For the detailed security status of libapache-session-ldap-perl please refer to
its security tracker page at:
https://security-tracker.debian.org/tracker/libapache-session-ldap-perl

Further information about Debian LTS security advisories, how to apply
these updates to your system and frequently asked questions can be
found at: https://wiki.debian.org/LTS


Severity
Package : libapache-session-ldap-perl
Version : 0.4-1+deb10u1
CVE ID : CVE-2020-36658

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.