Discover Government News

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200405-10
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Icecast denial of service vulnerability
      Date: May 19, 2004
      Bugs: #50935
        ID: 200405-10

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Icecast is vulnerable to a denial of service attack allowing remote
users to crash the application.

Background
=========
Icecast is a program that streams audio data to listeners over the
Internet.

Affected packages
================
    -------------------------------------------------------------------
     Package           /   Vulnerable   /                   Unaffected
    -------------------------------------------------------------------
  1  net-misc/icecast       <= 2.0.0                          >= 2.0.1

Description
==========
There is an out-of-bounds read error in the web interface of Icecast
when handling Basic Authorization requests. This vulnerability can
theorically be exploited by sending a specially crafted Authorization
header to the server.

Impact
=====
By exploiting this vulnerability, it is possible to crash the Icecast
server remotely, resulting in a denial of service attack.

Workaround
=========
There is no known workaround at this time. All users are advised to
upgrade to the latest available version of Icecast.

Resolution
=========
All users of Icecast should upgrade to the latest stable version:

    # emerge sync

    # emerge -pv ">=net-misc/icecast-2.0.1"
    # emerge ">=net-misc/icecast-2.0.1"

References
=========
  [ 1 ] Icecast 2.0.1 announcement
        
Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

     https://security.gentoo.org/glsa/200405-10

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org/.

License
======
Copyright 2004 Gentoo Technologies, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/1.0/

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
Comment: Using GnuPG with Mozilla - 
iD8DBQFAq53RvcL1obalX08RAqcNAJ4gZ4YdpevFjkRpLI5T2k7X/V7swACdGDOZ
ZJxICcqzvaB5M8+ZvEMoWdQ=kl6m
-----END PGP SIGNATURE-----

Gentoo: GLSA-200405-10: Icecast denial of service vulnerability

Icecast is vulnerable to a denial of service attack allowing remote users to crash the application.

Summary

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
Gentoo Linux Security Advisory                           GLSA 200405-10
                                            https://security.gentoo.org/

Severity: Normal Title: Icecast denial of service vulnerability Date: May 19, 2004 Bugs: #50935 ID: 200405-10

Synopsis ======= Icecast is vulnerable to a denial of service attack allowing remote users to crash the application.
Background ========= Icecast is a program that streams audio data to listeners over the Internet.
Affected packages ================ ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 net-misc/icecast <= 2.0.0 >= 2.0.1
========== There is an out-of-bounds read error in the web interface of Icecast when handling Basic Authorization requests. This vulnerability can theorically be exploited by sending a specially crafted Authorization header to the server.
Impact ===== By exploiting this vulnerability, it is possible to crash the Icecast server remotely, resulting in a denial of service attack.
Workaround ========= There is no known workaround at this time. All users are advised to upgrade to the latest available version of Icecast.
Resolution ========= All users of Icecast should upgrade to the latest stable version:
# emerge sync
# emerge -pv ">=net-misc/icecast-2.0.1" # emerge ">=net-misc/icecast-2.0.1"
References ========= [ 1 ] Icecast 2.0.1 announcement
Availability =========== This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/200405-10
Concerns? ======== Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org/.
License ====== Copyright 2004 Gentoo Technologies, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.
https://creativecommons.org/licenses/by-sa/1.0/
-----BEGIN PGP SIGNATURE----- Version: GnuPG v1.2.4 (GNU/Linux) Comment: Using GnuPG with Mozilla - iD8DBQFAq53RvcL1obalX08RAqcNAJ4gZ4YdpevFjkRpLI5T2k7X/V7swACdGDOZ ZJxICcqzvaB5M8+ZvEMoWdQ=kl6m -----END PGP SIGNATURE-----

Resolution

References

Availability

Concerns

Severity

Synopsis

Background

Affected Packages

Impact

Workaround

Related News