Discover Government News

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200405-16
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Multiple XSS Vulnerabilities in SquirrelMail
      Date: May 21, 2004
      Bugs: #49675
        ID: 200405-16

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
SquirrelMail is subject to several XSS and one SQL injection
vulnerability.

Background
=========
SquirrelMail is a webmail package written in PHP. It supports IMAP and
SMTP, and can optionally be installed with SQL support.

Affected packages
================
    -------------------------------------------------------------------
     Package                /   Vulnerable   /              Unaffected
    -------------------------------------------------------------------
  1  net-mail/squirrelmail       <= 1.4.2                 >= 1.4.3_rc1

Description
==========
Several unspecified cross-site scripting (XSS) vulnerabilities and a
well hidden SQL injection vulnerability were found. An XSS attack
allows an attacker to insert malicious code into a web-based
application. SquirrelMail does not check for code when parsing
variables received via the URL query string.

Impact
=====
One of the XSS vulnerabilities could be exploited by an attacker to
steal cookie-based authentication credentials from the user's browser.
The SQL injection issue could potentially be used by an attacker to run
arbitrary SQL commands inside the SquirrelMail database with privileges
of the SquirrelMail database user.

Workaround
=========
There is no known workaround at this time. All users are advised to
upgrade to version 1.4.3_rc1 or higher of SquirrelMail.

Resolution
=========
All SquirrelMail users should upgrade to the latest stable version:

    # emerge sync

    # emerge -pv ">=net-mail/squirrelmail-1.4.3_rc1"
    # emerge ">=net-mail/squirrelmail-1.4.3_rc1"

References
=========
  [ 1 ] SquirrelMail 1.4.3_rc1 release annoucement
        ;forum_id=1988
  [ 2 ] Bugtraq security annoucement
          [ 3 ] CERT description of XSS
        https://insights.sei.cmu.edu/library/2000-cert-advisories/

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

     https://security.gentoo.org/glsa/200405-16

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org/.

License
======
Copyright 2004 Gentoo Technologies, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/1.0/

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (Darwin)

iD8DBQFArkYbnt0v0zAqOHYRAsbCAKCgFyTi3benON9CIPi1Z/Zs85KXFgCeKOeF
SbrQqZQoiK2N2QPn8FuWUHw=HZpB
-----END PGP SIGNATURE-----

Gentoo: GLSA-200405-16: Multiple XSS Vulnerabilities in SquirrelMail

SquirrelMail is subject to several XSS and one SQL injection vulnerability.

Summary

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
Gentoo Linux Security Advisory                           GLSA 200405-16
                                            https://security.gentoo.org/

Severity: Normal Title: Multiple XSS Vulnerabilities in SquirrelMail Date: May 21, 2004 Bugs: #49675 ID: 200405-16

Synopsis ======= SquirrelMail is subject to several XSS and one SQL injection vulnerability.
Background ========= SquirrelMail is a webmail package written in PHP. It supports IMAP and SMTP, and can optionally be installed with SQL support.
Affected packages ================ ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 net-mail/squirrelmail <= 1.4.2 >= 1.4.3_rc1
========== Several unspecified cross-site scripting (XSS) vulnerabilities and a well hidden SQL injection vulnerability were found. An XSS attack allows an attacker to insert malicious code into a web-based application. SquirrelMail does not check for code when parsing variables received via the URL query string.
Impact ===== One of the XSS vulnerabilities could be exploited by an attacker to steal cookie-based authentication credentials from the user's browser. The SQL injection issue could potentially be used by an attacker to run arbitrary SQL commands inside the SquirrelMail database with privileges of the SquirrelMail database user.
Workaround ========= There is no known workaround at this time. All users are advised to upgrade to version 1.4.3_rc1 or higher of SquirrelMail.
Resolution ========= All SquirrelMail users should upgrade to the latest stable version:
# emerge sync
# emerge -pv ">=net-mail/squirrelmail-1.4.3_rc1" # emerge ">=net-mail/squirrelmail-1.4.3_rc1"
References ========= [ 1 ] SquirrelMail 1.4.3_rc1 release annoucement ;forum_id=1988 [ 2 ] Bugtraq security annoucement [ 3 ] CERT description of XSS https://insights.sei.cmu.edu/library/2000-cert-advisories/
Availability =========== This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/200405-16
Concerns? ======== Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org/.
License ====== Copyright 2004 Gentoo Technologies, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.
https://creativecommons.org/licenses/by-sa/1.0/
-----BEGIN PGP SIGNATURE----- Version: GnuPG v1.2.3 (Darwin)
iD8DBQFArkYbnt0v0zAqOHYRAsbCAKCgFyTi3benON9CIPi1Z/Zs85KXFgCeKOeF SbrQqZQoiK2N2QPn8FuWUHw=HZpB -----END PGP SIGNATURE-----

Resolution

References

Availability

Concerns

Severity

Synopsis

Background

Affected Packages

Impact

Workaround

Related News