Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200407-08
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Ethereal: Multiple security problems
      Date: July 09, 2004
      Bugs: #56423
        ID: 200407-08

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Multiple vulnerabilities including one buffer overflow exist in
Ethereal, which may allow an attacker to run arbitrary code or crash
the program.

Background
=========
Ethereal is a feature rich network protocol analyzer.

Affected packages
================
    -------------------------------------------------------------------
     Package                /   Vulnerable   /              Unaffected
    -------------------------------------------------------------------
  1  net-analyzer/ethereal       <= 0.10.4                   >= 0.10.5

Description
==========
There are multiple vulnerabilities in versions of Ethereal earlier than
0.10.5, including:

* In some cases the iSNS dissector could cause Ethereal to abort.

* If there was no policy name for a handle for SMB SID snooping it
  could cause a crash.

* A malformed or missing community string could cause the SNMP
  dissector to crash.

Impact
=====
An attacker could use these vulnerabilities to crash Ethereal or even
execute arbitrary code with the permissions of the user running
Ethereal, which could be the root user.

Workaround
=========
For a temporary workaround you can disable all affected protocol
dissectors by selecting Analyze->Enabled Protocols... and deselecting
them from the list. For SMB you can disable SID snooping in the SMB
protocol preference. However, it is strongly recommended to upgrade to
the latest stable version.

Resolution
=========
All Ethereal users should upgrade to the latest stable version:

    # emerge sync

    # emerge -pv ">=net-analyzer/ethereal-0.10.5"
    # emerge ">=net-analyzer/ethereal-0.10.5"

References
=========
  [ 1 ] Ethereal enpa-sa-00015
        
Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

    https://security.gentoo.org/glsa/200407-08

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org/.

License
======
Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/1.0/

Gentoo: GLSA-200407-08: Ethereal: Multiple security problems

Multiple vulnerabilities including one buffer overflow exist in Ethereal, which may allow an attacker to run arbitrary code or crash the program

Summary

Gentoo Linux Security Advisory GLSA 200407-08 https://security.gentoo.org/ Severity: High Title: Ethereal: Multiple security problems Date: July 09, 2004 Bugs: #56423 ID: 200407-08

Synopsis ======= Multiple vulnerabilities including one buffer overflow exist in Ethereal, which may allow an attacker to run arbitrary code or crash the program.
Background ========= Ethereal is a feature rich network protocol analyzer.
Affected packages ================ ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 net-analyzer/ethereal <= 0.10.4 >= 0.10.5
========== There are multiple vulnerabilities in versions of Ethereal earlier than 0.10.5, including:
* In some cases the iSNS dissector could cause Ethereal to abort.
* If there was no policy name for a handle for SMB SID snooping it could cause a crash.
* A malformed or missing community string could cause the SNMP dissector to crash.
Impact ===== An attacker could use these vulnerabilities to crash Ethereal or even execute arbitrary code with the permissions of the user running Ethereal, which could be the root user.
Workaround ========= For a temporary workaround you can disable all affected protocol dissectors by selecting Analyze->Enabled Protocols... and deselecting them from the list. For SMB you can disable SID snooping in the SMB protocol preference. However, it is strongly recommended to upgrade to the latest stable version.
Resolution ========= All Ethereal users should upgrade to the latest stable version:
# emerge sync
# emerge -pv ">=net-analyzer/ethereal-0.10.5" # emerge ">=net-analyzer/ethereal-0.10.5"
References ========= [ 1 ] Ethereal enpa-sa-00015
Availability =========== This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/200407-08
Concerns? ======== Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org/.
License ====== Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.
https://creativecommons.org/licenses/by-sa/1.0/

Resolution

References

Availability

Concerns

Severity

Synopsis

Background

Affected Packages

Impact

Workaround

Related News