Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200409-24
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: Foomatic: Arbitrary command execution in foomatic-rip
            filter
      Date: September 20, 2004
      Bugs: #64166
        ID: 200409-24

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
The foomatic-rip filter in foomatic-filters contains a vulnerability
which may allow arbitrary command execution on the print server.

Background
=========
Foomatic is a system for connecting printer drivers with spooler
systems such as CUPS and LPD. The foomatic-filters package contains
wrapper scripts which are designed to be used with Foomatic.

Affected packages
================
    -------------------------------------------------------------------
     Package                     /  Vulnerable  /           Unaffected
    -------------------------------------------------------------------
  1  net-print/foomatic              <= 3.0.1                 >= 3.0.2
  2  net-print/foomatic-filters      <= 3.0.1                 >= 3.0.2
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
==========
There is a vulnerability in the foomatic-filters package. This
vulnerability is due to insufficient checking of command-line
parameters and environment variables in the foomatic-rip filter.

Impact
=====
This vulnerability may allow both local and remote attackers to execute
arbitrary commands on the print server with the permissions of the
spooler (oftentimes the "lp" user).

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All foomatic users should upgrade to the latest version:

    # emerge sync

    # emerge -pv ">=net-print/foomatic-3.0.2"
    # emerge ">=net-print/foomatic-3.0.2"

PLEASE NOTE: You should update foomatic, instead of foomatic-filters.
This will help to ensure that all other foomatic components remain
functional.

References
=========
  [ 1 ] Foomatic Announcement
          [ 2 ] Mandrakesoft Security Advisory
          [ 3 ] CAN 2004-0801
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0801

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/200409-24

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org/.

License
======
Copyright 2004 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/1.0/

Gentoo: GLSA-200409-24: Foomatic: Arbitrary command execution in foomatic-rip filter

The foomatic-rip filter in foomatic-filters contains a vulnerability which may allow arbitrary command execution on the print server.

Summary

Gentoo Linux Security Advisory GLSA 200409-24 https://security.gentoo.org/ Severity: High Title: Foomatic: Arbitrary command execution in foomatic-rip filter Date: September 20, 2004 Bugs: #64166 ID: 200409-24

Synopsis ======= The foomatic-rip filter in foomatic-filters contains a vulnerability which may allow arbitrary command execution on the print server.
Background ========= Foomatic is a system for connecting printer drivers with spooler systems such as CUPS and LPD. The foomatic-filters package contains wrapper scripts which are designed to be used with Foomatic.
Affected packages ================ ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 net-print/foomatic <= 3.0.1 >= 3.0.2 2 net-print/foomatic-filters <= 3.0.1 >= 3.0.2 ------------------------------------------------------------------- 2 affected packages on all of their supported architectures. -------------------------------------------------------------------
========== There is a vulnerability in the foomatic-filters package. This vulnerability is due to insufficient checking of command-line parameters and environment variables in the foomatic-rip filter.
Impact ===== This vulnerability may allow both local and remote attackers to execute arbitrary commands on the print server with the permissions of the spooler (oftentimes the "lp" user).
Workaround ========= There is no known workaround at this time.
Resolution ========= All foomatic users should upgrade to the latest version:
# emerge sync
# emerge -pv ">=net-print/foomatic-3.0.2" # emerge ">=net-print/foomatic-3.0.2"
PLEASE NOTE: You should update foomatic, instead of foomatic-filters. This will help to ensure that all other foomatic components remain functional.
References ========= [ 1 ] Foomatic Announcement [ 2 ] Mandrakesoft Security Advisory [ 3 ] CAN 2004-0801 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2004-0801
Availability =========== This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/200409-24
Concerns? ======== Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org/.
License ====== Copyright 2004 Gentoo Foundation, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.
https://creativecommons.org/licenses/by-sa/1.0/

Resolution

References

Availability

Concerns

Severity

Synopsis

Background

Affected Packages

Impact

Workaround

Related News