Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200501-39
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: High
     Title: SquirrelMail: Multiple vulnerabilities
      Date: January 28, 2005
      Bugs: #78116
        ID: 200501-39

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
SquirrelMail fails to properly sanitize user input, which could lead to
arbitrary code execution and compromise webmail accounts.

Background
=========
SquirrelMail is a webmail package written in PHP. It supports IMAP and
SMTP and can optionally be installed with SQL support.

Affected packages
================
    -------------------------------------------------------------------
     Package                   /   Vulnerable   /           Unaffected
    -------------------------------------------------------------------
  1  mail-client/squirrelmail     <= 1.4.3a-r2                >= 1.4.4

Description
==========
SquirrelMail fails to properly sanitize certain strings when decoding
specially-crafted strings, which can lead to PHP file inclusion and
XSS.

* Insufficient checking of incoming URLs in prefs.php (CAN-2005-0075)
  and in webmail.php (CAN-2005-0103).

* Insufficient escaping of integers in webmail.php (CAN-2005-0104).

Impact
=====
By sending a specially-crafted URL, an attacker can execute arbitrary
code from the local system with the permissions of the web server.
Furthermore by enticing a user to load a specially-crafted URL, it is
possible to display arbitrary remote web pages in Squirrelmail's
frameset and execute arbitrary scripts running in the context of the
victim's browser. This could lead to a compromise of the user's webmail
account, cookie theft, etc.

Workaround
=========
The arbitrary code execution is only possible with "register_globals"
set to "On". Gentoo ships PHP with "register_globals" set to "Off" by
default. There are no known workarounds for the other issues at this
time.

Resolution
=========
All SquirrelMail users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=mail-client/squirrelmail-1.4.4"

Note: Users with the vhosts USE flag set should manually use
webapp-config to finalize the update.

References
=========
  [ 1 ] SquirrelMail Advisory
          [ 2 ] CAN-2005-0075
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0075
  [ 3 ] CAN-2005-0103
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0103
  [ 4 ] CAN-2005-0104
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0104

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/200501-39

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org/.

License
======
Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.0/

Gentoo: GLSA-200501-39: SquirrelMail: Multiple vulnerabilities

SquirrelMail fails to properly sanitize user input, which could lead to arbitrary code execution and compromise webmail accounts.

Summary

Gentoo Linux Security Advisory GLSA 200501-39 https://security.gentoo.org/ Severity: High Title: SquirrelMail: Multiple vulnerabilities Date: January 28, 2005 Bugs: #78116 ID: 200501-39

Synopsis ======= SquirrelMail fails to properly sanitize user input, which could lead to arbitrary code execution and compromise webmail accounts.
Background ========= SquirrelMail is a webmail package written in PHP. It supports IMAP and SMTP and can optionally be installed with SQL support.
Affected packages ================ ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 mail-client/squirrelmail <= 1.4.3a-r2 >= 1.4.4
========== SquirrelMail fails to properly sanitize certain strings when decoding specially-crafted strings, which can lead to PHP file inclusion and XSS.
* Insufficient checking of incoming URLs in prefs.php (CAN-2005-0075) and in webmail.php (CAN-2005-0103).
* Insufficient escaping of integers in webmail.php (CAN-2005-0104).
Impact ===== By sending a specially-crafted URL, an attacker can execute arbitrary code from the local system with the permissions of the web server. Furthermore by enticing a user to load a specially-crafted URL, it is possible to display arbitrary remote web pages in Squirrelmail's frameset and execute arbitrary scripts running in the context of the victim's browser. This could lead to a compromise of the user's webmail account, cookie theft, etc.
Workaround ========= The arbitrary code execution is only possible with "register_globals" set to "On". Gentoo ships PHP with "register_globals" set to "Off" by default. There are no known workarounds for the other issues at this time.
Resolution ========= All SquirrelMail users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=mail-client/squirrelmail-1.4.4"
Note: Users with the vhosts USE flag set should manually use webapp-config to finalize the update.
References ========= [ 1 ] SquirrelMail Advisory [ 2 ] CAN-2005-0075 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0075 [ 3 ] CAN-2005-0103 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0103 [ 4 ] CAN-2005-0104 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0104
Availability =========== This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/200501-39
Concerns? ======== Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org/.
License ====== Copyright 2005 Gentoo Foundation, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.
https://creativecommons.org/licenses/by-sa/2.0/

Resolution

References

Availability

Concerns

Severity

Synopsis

Background

Affected Packages

Impact

Workaround

Related News