Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200506-12
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Low
     Title: MediaWiki: Cross-site scripting vulnerability
      Date: June 13, 2005
      Bugs: #95255
        ID: 200506-12

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
MediaWiki is vulnerable to a cross-site scripting attack that could
allow arbitrary scripting code execution.

Background
=========
MediaWiki is a collaborative editing software, used by big projects
like Wikipedia.

Affected packages
================
    -------------------------------------------------------------------
     Package             /  Vulnerable  /                   Unaffected
    -------------------------------------------------------------------
  1  www-apps/mediawiki       < 1.4.5                         >= 1.4.5
                                                            *>= 1.3.13

Description
==========
MediaWiki incorrectly handles page template inclusions, rendering it
vulnerable to cross-site scripting attacks.

Impact
=====
A remote attacker could exploit this vulnerability to inject malicious
script code that will be executed in a user's browser session in the
context of the vulnerable site.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All MediaWiki users should upgrade to the latest available versions:

    # emerge --sync
    # emerge --ask --oneshot --verbose www-apps/mediawiki

References
=========
  [ 1 ] MediaWiki 1.4.5 Release Notes
        
Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/200506-12

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org/.

License
======
Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.0/

Gentoo: GLSA-200506-12: MediaWiki: Cross-site scripting vulnerability

MediaWiki is vulnerable to a cross-site scripting attack that could allow arbitrary scripting code execution.

Summary

Gentoo Linux Security Advisory GLSA 200506-12 https://security.gentoo.org/ Severity: Low Title: MediaWiki: Cross-site scripting vulnerability Date: June 13, 2005 Bugs: #95255 ID: 200506-12

Synopsis ======= MediaWiki is vulnerable to a cross-site scripting attack that could allow arbitrary scripting code execution.
Background ========= MediaWiki is a collaborative editing software, used by big projects like Wikipedia.
Affected packages ================ ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 www-apps/mediawiki < 1.4.5 >= 1.4.5 *>= 1.3.13
========== MediaWiki incorrectly handles page template inclusions, rendering it vulnerable to cross-site scripting attacks.
Impact ===== A remote attacker could exploit this vulnerability to inject malicious script code that will be executed in a user's browser session in the context of the vulnerable site.
Workaround ========= There is no known workaround at this time.
Resolution ========= All MediaWiki users should upgrade to the latest available versions:
# emerge --sync # emerge --ask --oneshot --verbose www-apps/mediawiki
References ========= [ 1 ] MediaWiki 1.4.5 Release Notes
Availability =========== This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/200506-12
Concerns? ======== Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org/.
License ====== Copyright 2005 Gentoo Foundation, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.
https://creativecommons.org/licenses/by-sa/2.0/

Resolution

References

Availability

Concerns

Severity

Synopsis

Background

Affected Packages

Impact

Workaround

Related News