Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200510-26
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: XLI, Xloadimage: Buffer overflow
      Date: October 30, 2005
      Bugs: #108365
        ID: 200510-26

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
XLI and Xloadimage contain a vulnerability which could potentially
result in the execution of arbitrary code.

Background
=========
XLI and Xloadimage are X11 image manipulation utilities.

Affected packages
================
    -------------------------------------------------------------------
     Package               /   Vulnerable   /               Unaffected
    -------------------------------------------------------------------
  1  media-gfx/xli             < 1.17.0-r2                >= 1.17.0-r2
  2  media-gfx/xloadimage       < 4.1-r4                     >= 4.1-r4
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
==========
When XLI or Xloadimage process an image, they create a new image object
to contain the new image, copying the title from the old image to the
newly created image. Ariel Berkman reported that the 'zoom', 'reduce',
and 'rotate' functions use a fixed length buffer to contain the new
title, which could be overwritten by the NIFF or XPM image processors.

Impact
=====
A malicious user could craft a malicious XPM or NIFF file and entice a
user to view it using XLI, or manipulate it using Xloadimage,
potentially resulting in the execution of arbitrary code with the
permissions of the user running XLI or Xloadimage.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All XLI users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=media-gfx/xli-1.17.0-r2"

All Xloadimage users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=media-gfx/xloadimage-4.1-r4"

References
=========
  [ 1 ] CAN-2005-3178
        
Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/200510-26

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org/.

License
======
Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.0/

Gentoo: GLSA-200510-26: XLI, Xloadimage: Buffer overflow

XLI and Xloadimage contain a vulnerability which could potentially result in the execution of arbitrary code.

Summary

Gentoo Linux Security Advisory GLSA 200510-26 https://security.gentoo.org/ Severity: Normal Title: XLI, Xloadimage: Buffer overflow Date: October 30, 2005 Bugs: #108365 ID: 200510-26

Synopsis ======= XLI and Xloadimage contain a vulnerability which could potentially result in the execution of arbitrary code.
Background ========= XLI and Xloadimage are X11 image manipulation utilities.
Affected packages ================ ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 media-gfx/xli < 1.17.0-r2 >= 1.17.0-r2 2 media-gfx/xloadimage < 4.1-r4 >= 4.1-r4 ------------------------------------------------------------------- 2 affected packages on all of their supported architectures. -------------------------------------------------------------------
========== When XLI or Xloadimage process an image, they create a new image object to contain the new image, copying the title from the old image to the newly created image. Ariel Berkman reported that the 'zoom', 'reduce', and 'rotate' functions use a fixed length buffer to contain the new title, which could be overwritten by the NIFF or XPM image processors.
Impact ===== A malicious user could craft a malicious XPM or NIFF file and entice a user to view it using XLI, or manipulate it using Xloadimage, potentially resulting in the execution of arbitrary code with the permissions of the user running XLI or Xloadimage.
Workaround ========= There is no known workaround at this time.
Resolution ========= All XLI users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-gfx/xli-1.17.0-r2"
All Xloadimage users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-gfx/xloadimage-4.1-r4"
References ========= [ 1 ] CAN-2005-3178
Availability =========== This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/200510-26
Concerns? ======== Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org/.
License ====== Copyright 2005 Gentoo Foundation, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.
https://creativecommons.org/licenses/by-sa/2.0/

Resolution

References

Availability

Concerns

Severity

Synopsis

Background

Affected Packages

Impact

Workaround

Related News