Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200710-29
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Sylpheed, Claws Mail: User-assisted remote execution of
            arbitrary code
      Date: October 25, 2007
      Bugs: #190104
        ID: 200710-29

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
A format string error has been discovered in Sylpheed and Claws Mail,
potentially leading to the remote execution of arbitrary code.

Background
=========
Sylpheed and Claws Mail are two GTK based e-mail clients.

Affected packages
================
    -------------------------------------------------------------------
     Package                 /  Vulnerable  /               Unaffected
    -------------------------------------------------------------------
  1  mail-client/sylpheed         < 2.4.5                     >= 2.4.5
  2  mail-client/claws-mail       < 3.0.0                     >= 3.0.0
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
==========
Ulf Harnhammar from Secunia Research discovered a format string error
in the inc_put_error() function in file src/inc.c.

Impact
=====
A remote attacker could entice a user to connect to a malicious POP
server sending specially crafted replies, possibly resulting in the
execution of arbitrary code with the privileges of the user running the
application.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All Sylpheed users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=mail-client/sylpheed-2.4.5"

All Claws Mail users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=mail-client/claws-mail-3.0.0"

References
=========
  [ 1 ] CVE-2007-2958
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2958

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/200710-29

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org/.

License
======
Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-200710-29: Sylpheed, Claws Mail: User-assisted remote execution of arbitrary code

A format string error has been discovered in Sylpheed and Claws Mail, potentially leading to the remote execution of arbitrary code.

Summary

Gentoo Linux Security Advisory GLSA 200710-29 https://security.gentoo.org/ Severity: Normal Title: Sylpheed, Claws Mail: User-assisted remote execution of arbitrary code Date: October 25, 2007 Bugs: #190104 ID: 200710-29

Synopsis ======= A format string error has been discovered in Sylpheed and Claws Mail, potentially leading to the remote execution of arbitrary code.
Background ========= Sylpheed and Claws Mail are two GTK based e-mail clients.
Affected packages ================ ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 mail-client/sylpheed < 2.4.5 >= 2.4.5 2 mail-client/claws-mail < 3.0.0 >= 3.0.0 ------------------------------------------------------------------- 2 affected packages on all of their supported architectures. -------------------------------------------------------------------
========== Ulf Harnhammar from Secunia Research discovered a format string error in the inc_put_error() function in file src/inc.c.
Impact ===== A remote attacker could entice a user to connect to a malicious POP server sending specially crafted replies, possibly resulting in the execution of arbitrary code with the privileges of the user running the application.
Workaround ========= There is no known workaround at this time.
Resolution ========= All Sylpheed users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=mail-client/sylpheed-2.4.5"
All Claws Mail users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=mail-client/claws-mail-3.0.0"
References ========= [ 1 ] CVE-2007-2958 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-2958
Availability =========== This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/200710-29
Concerns? ======== Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org/.
License ====== Copyright 2007 Gentoo Foundation, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.
https://creativecommons.org/licenses/by-sa/2.5/

Resolution

References

Availability

Concerns

Severity

Synopsis

Background

Affected Packages

Impact

Workaround

Related News