Discover Government News

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200711-25
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: MySQL: Denial of Service
      Date: November 18, 2007
      Bugs: #198988
        ID: 200711-25

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
A Denial of Service vulnerability was found in MySQL.

Background
=========
MySQL is a popular multi-threaded, multi-user SQL server.

Affected packages
================
    -------------------------------------------------------------------
     Package       /   Vulnerable   /                       Unaffected
    -------------------------------------------------------------------
  1  dev-db/mysql      < 5.0.44-r2                        >= 5.0.44-r2

Description
==========
Joe Gallo and Artem Russakovskii reported an error in the
convert_search_mode_to_innobase() function in ha_innodb.cc in the
InnoDB engine that is leading to a failed assertion when handling
CONTAINS operations.

Impact
=====
A remote authenticated attacker with ALTER privileges could send a
specially crafted request to a vulnerable database server possibly
leading to a Denial of Service.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All MySQL users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=dev-db/mysql-5.0.44-r2"

References
=========
  [ 1 ] CVE-2007-5925
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-5925

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/200711-25

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org/.

License
======
Copyright 2007 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - 
iD8DBQFHQLPVuhJ+ozIKI5gRAvNFAJwMO0s6m2J1Bcqq+ijMED9FAWgMewCZAVmB
lM7jI2TrO3q//snoBFgHL6U=OVzF
-----END PGP SIGNATURE-----

Gentoo: GLSA-200711-25: MySQL: Denial of Service

A Denial of Service vulnerability was found in MySQL.

Summary

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
Gentoo Linux Security Advisory                           GLSA 200711-25
                                            https://security.gentoo.org/

Severity: Normal Title: MySQL: Denial of Service Date: November 18, 2007 Bugs: #198988 ID: 200711-25

Synopsis ======= A Denial of Service vulnerability was found in MySQL.
Background ========= MySQL is a popular multi-threaded, multi-user SQL server.
Affected packages ================ ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 dev-db/mysql < 5.0.44-r2 >= 5.0.44-r2
========== Joe Gallo and Artem Russakovskii reported an error in the convert_search_mode_to_innobase() function in ha_innodb.cc in the InnoDB engine that is leading to a failed assertion when handling CONTAINS operations.
Impact ===== A remote authenticated attacker with ALTER privileges could send a specially crafted request to a vulnerable database server possibly leading to a Denial of Service.
Workaround ========= There is no known workaround at this time.
Resolution ========= All MySQL users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-db/mysql-5.0.44-r2"
References ========= [ 1 ] CVE-2007-5925 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-5925
Availability =========== This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/200711-25
Concerns? ======== Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org/.
License ====== Copyright 2007 Gentoo Foundation, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.
https://creativecommons.org/licenses/by-sa/2.5/ -----BEGIN PGP SIGNATURE----- Version: GnuPG v1.4.7 (GNU/Linux) Comment: Using GnuPG with Mozilla - iD8DBQFHQLPVuhJ+ozIKI5gRAvNFAJwMO0s6m2J1Bcqq+ijMED9FAWgMewCZAVmB lM7jI2TrO3q//snoBFgHL6U=OVzF -----END PGP SIGNATURE-----

Resolution

References

Availability

Concerns

Severity

Synopsis

Background

Affected Packages

Impact

Workaround

Related News