Debian Linux Distribution

Find the information you need for your favorite open source distribution .

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200803-17
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: PDFlib: Multiple buffer overflows
      Date: March 10, 2008
      Bugs: #203287
        ID: 200803-17

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Multiple stack-based buffer overflows have been reported in PDFlib.

Background
=========
PDFlib is a library for generating PDF on the fly.

Affected packages
================
    -------------------------------------------------------------------
     Package            /  Vulnerable  /                    Unaffected
    -------------------------------------------------------------------
  1  media-libs/pdflib     < 7.0.2_p8                      >= 7.0.2_p8

Description
==========
poplix reported multiple boundary errors in the pdc_fsearch_fopen()
function when processing overly long filenames.

Impact
=====
A remote attacker could send specially crafted content to a vulnerable
application using PDFlib, possibly resulting in the remote execution of
arbitrary code with the privileges of the user running the application.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All PDFlib users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=media-libs/pdflib-7.0.2_p8"

References
=========
  [ 1 ] CVE-2007-6561
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6561

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/200803-17

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org/.

License
======
Copyright 2008 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.7 (GNU/Linux)
Comment: Using GnuPG with Mozilla - 
iD8DBQFH1bcyuhJ+ozIKI5gRAqWDAJ9nAoYSMiv8M4BizsKK16yDrFo3HQCgno+N
1w7uxj8ylAaRgyI2ckCJhj4=09TR
-----END PGP SIGNATURE-----

Gentoo: GLSA-200803-17: PDFlib: Multiple buffer overflows

Multiple stack-based buffer overflows have been reported in PDFlib.

Summary

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
Gentoo Linux Security Advisory                           GLSA 200803-17
                                            https://security.gentoo.org/

Severity: Normal Title: PDFlib: Multiple buffer overflows Date: March 10, 2008 Bugs: #203287 ID: 200803-17

Synopsis ======= Multiple stack-based buffer overflows have been reported in PDFlib.
Background ========= PDFlib is a library for generating PDF on the fly.
Affected packages ================ ------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 media-libs/pdflib < 7.0.2_p8 >= 7.0.2_p8
========== poplix reported multiple boundary errors in the pdc_fsearch_fopen() function when processing overly long filenames.
Impact ===== A remote attacker could send specially crafted content to a vulnerable application using PDFlib, possibly resulting in the remote execution of arbitrary code with the privileges of the user running the application.
Workaround ========= There is no known workaround at this time.
Resolution ========= All PDFlib users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=media-libs/pdflib-7.0.2_p8"
References ========= [ 1 ] CVE-2007-6561 http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2007-6561
Availability =========== This GLSA and any updates to it are available for viewing at the Gentoo Security Website:
https://security.gentoo.org/glsa/200803-17
Concerns? ======== Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org/.
License ====== Copyright 2008 Gentoo Foundation, Inc; referenced text belongs to its owner(s).
The contents of this document are licensed under the Creative Commons - Attribution / Share Alike license.
https://creativecommons.org/licenses/by-sa/2.5/ -----BEGIN PGP SIGNATURE----- Version: GnuPG v2.0.7 (GNU/Linux) Comment: Using GnuPG with Mozilla - iD8DBQFH1bcyuhJ+ozIKI5gRAqWDAJ9nAoYSMiv8M4BizsKK16yDrFo3HQCgno+N 1w7uxj8ylAaRgyI2ckCJhj4=09TR -----END PGP SIGNATURE-----

Resolution

References

Availability

Concerns

Severity

Synopsis

Background

Affected Packages

Impact

Workaround

Related News