Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201401-26
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: Zabbix: Shell command injection
     Date: January 23, 2014
     Bugs: #493250
       ID: 201401-26

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
A vulnerability in Zabbix could allow remote attackers to execute
arbitrary shell code.

Background
=========
Zabbix is software for monitoring applications, networks, and servers.

Affected packages
================
    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-analyzer/zabbix         < 2.2.0-r4               >= 2.2.0-r4
                                                         *>= 2.0.9-r1

Description
==========
If a flexible user parameter is configured in Zabbix agent, including a
newline in the parameters will execute newline section as a separate
command even if UnsafeUserParameters are disabled.

Impact
=====
A remote attacker could possibly execute arbitrary shell code with the
privileges of the process.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All Zabbix 2.2 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-analyzer/zabbix-2.2.0-r4"

All Zabbix 2.0 users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-analyzer/zabbix-2.0.9-r1"

References
=========
[ 1 ] CVE-2013-6824
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-6824

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201401-26

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
======
Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-201401-26: Zabbix: Shell command injection

A vulnerability in Zabbix could allow remote attackers to execute arbitrary shell code.

Summary

If a flexible user parameter is configured in Zabbix agent, including a newline in the parameters will execute newline section as a separate command even if UnsafeUserParameters are disabled.

Resolution

All Zabbix 2.2 users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=net-analyzer/zabbix-2.2.0-r4"
All Zabbix 2.0 users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-analyzer/zabbix-2.0.9-r1"

References

[ 1 ] CVE-2013-6824 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2013-6824

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website: https://security.gentoo.org/glsa/201401-26

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: High
Title: Zabbix: Shell command injection
Date: January 23, 2014
Bugs: #493250
ID: 201401-26

Synopsis

A vulnerability in Zabbix could allow remote attackers to execute arbitrary shell code.

Background

Zabbix is software for monitoring applications, networks, and servers.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 net-analyzer/zabbix < 2.2.0-r4 >= 2.2.0-r4 *>= 2.0.9-r1

Impact

===== A remote attacker could possibly execute arbitrary shell code with the privileges of the process.

Workaround

There is no known workaround at this time.

Related News