Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201405-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: Normal
    Title: Asterisk: Denial of Service
     Date: May 03, 2014
     Bugs: #504180
       ID: 201405-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
Multiple buffer overflows in Asterisk might allow remote attackers to
cause a Denial of Service condition.

Background
=========
Asterisk is an open source telephony engine and toolkit.

Affected packages
================
    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  net-misc/asterisk            < 11.8.1               *>= 1.8.26.1
                                                            >= 11.8.1

Description
==========
Multiple vulnerabilities have been discovered in Asterisk. Please
review the CVE identifiers and Asterisk Project Security Advisories
referenced below for details.

Impact
=====
A remote attacker could possibly cause a Denial of Service condition.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All Asterisk 11.* users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/asterisk-11.8.1"

All Asterisk 1.8.* users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.8.26.1"

References
=========
[ 1 ] AST-2014-001
      http://downloads.asterisk.org/pub/security/AST-2014-001.pdf
[ 2 ] AST-2014-002
      http://downloads.asterisk.org/pub/security/AST-2014-002.pdf
[ 3 ] AST-2014-003
      http://downloads.asterisk.org/pub/security/AST-2014-003.pdf
[ 4 ] AST-2014-004
      http://downloads.asterisk.org/pub/security/AST-2014-004.pdf
[ 5 ] CVE-2014-2286
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2286
[ 6 ] CVE-2014-2287
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2287
[ 7 ] CVE-2014-2288
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2288
[ 8 ] CVE-2014-2289
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2289

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201405-05

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
======
Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-201405-05: Asterisk: Denial of Service

Multiple buffer overflows in Asterisk might allow remote attackers to cause a Denial of Service condition.

Summary

Multiple vulnerabilities have been discovered in Asterisk. Please review the CVE identifiers and Asterisk Project Security Advisories referenced below for details.

Resolution

All Asterisk 11.* users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=net-misc/asterisk-11.8.1"
All Asterisk 1.8.* users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=net-misc/asterisk-1.8.26.1"

References

[ 1 ] AST-2014-001 http://downloads.asterisk.org/pub/security/AST-2014-001.pdf [ 2 ] AST-2014-002 http://downloads.asterisk.org/pub/security/AST-2014-002.pdf [ 3 ] AST-2014-003 http://downloads.asterisk.org/pub/security/AST-2014-003.pdf [ 4 ] AST-2014-004 http://downloads.asterisk.org/pub/security/AST-2014-004.pdf [ 5 ] CVE-2014-2286 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2286 [ 6 ] CVE-2014-2287 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2287 [ 7 ] CVE-2014-2288 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2288 [ 8 ] CVE-2014-2289 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-2289

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website: https://security.gentoo.org/glsa/201405-05

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: Normal
Title: Asterisk: Denial of Service
Date: May 03, 2014
Bugs: #504180
ID: 201405-05

Synopsis

Multiple buffer overflows in Asterisk might allow remote attackers to cause a Denial of Service condition.

Background

Asterisk is an open source telephony engine and toolkit.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 net-misc/asterisk < 11.8.1 *>= 1.8.26.1 >= 11.8.1

Impact

===== A remote attacker could possibly cause a Denial of Service condition.

Workaround

There is no known workaround at this time.

Related News