Discover Government News

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 201406-01
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: D-Bus, GLib: Privilege escalation
     Date: June 01, 2014
     Bugs: #436028
       ID: 201406-01

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
=======
A vulnerability has been found in D-Bus which allows local attackers to
gain escalated privileges.

Background
=========
D-Bus is a daemon providing a framework for applications to communicate
with one another. GLib is a library providing a number of GNOME's core
objects and functions.

Affected packages
================
    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  sys-apps/dbus                < 1.6.8                    >= 1.6.8
  2  dev-libs/glib              < 2.32.4-r1              >= 2.32.4-r1
    -------------------------------------------------------------------
     2 affected packages

Description
==========
When libdbus is used in a setuid program, a user can gain escalated
privileges by leveraging the DBUS_SYSTEM_BUS_ADDRESS variable. GLib can
be used in a setuid context with D-Bus, and so can trigger this
vulnerability. Please review the CVE identifier below for more details.

Impact
=====
A local attacker could gain escalated privileges and execute arbitrary
code.

Workaround
=========
There is no known workaround at this time.

Resolution
=========
All D-Bus users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=sys-apps/dbus-1.6.8"

All GLib users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-libs/glib-2.32.4-r1"

References
=========
[ 1 ] CVE-2012-3524
      http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-3524

Availability
===========
This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/201406-01

Concerns?
========
Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
======
Copyright 2014 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5/

Gentoo: GLSA-201406-01: D-Bus, GLib: Privilege escalation

A vulnerability has been found in D-Bus which allows local attackers to gain escalated privileges.

Summary

When libdbus is used in a setuid program, a user can gain escalated privileges by leveraging the DBUS_SYSTEM_BUS_ADDRESS variable. GLib can be used in a setuid context with D-Bus, and so can trigger this vulnerability. Please review the CVE identifier below for more details.

Resolution

All D-Bus users should upgrade to the latest version: # emerge --sync # emerge --ask --oneshot --verbose ">=sys-apps/dbus-1.6.8"
All GLib users should upgrade to the latest version:
# emerge --sync # emerge --ask --oneshot --verbose ">=dev-libs/glib-2.32.4-r1"

References

[ 1 ] CVE-2012-3524 http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-3524

Availability

This GLSA and any updates to it are available for viewing at the Gentoo Security Website: https://security.gentoo.org/glsa/201406-01

Concerns

Security is a primary focus of Gentoo Linux and ensuring the confidentiality and security of our users' machines is of utmost importance to us. Any security concerns should be addressed to security@gentoo.org or alternatively, you may file a bug at https://bugs.gentoo.org.

Severity
Severity: High
Title: D-Bus, GLib: Privilege escalation
Date: June 01, 2014
Bugs: #436028
ID: 201406-01

Synopsis

A vulnerability has been found in D-Bus which allows local attackers to gain escalated privileges.

Background

D-Bus is a daemon providing a framework for applications to communicate with one another. GLib is a library providing a number of GNOME's core objects and functions.

Affected Packages

------------------------------------------------------------------- Package / Vulnerable / Unaffected ------------------------------------------------------------------- 1 sys-apps/dbus < 1.6.8 >= 1.6.8 2 dev-libs/glib < 2.32.4-r1 >= 2.32.4-r1 ------------------------------------------------------------------- 2 affected packages

Impact

===== A local attacker could gain escalated privileges and execute arbitrary code.

Workaround

There is no known workaround at this time.

Related News