Gentoo: GLSA-201406-31: Konqueror: Multiple vulnerabilities

    Date27 Jun 2014
    CategoryGentoo
    25
    Posted ByLinuxSecurity Advisories
    Multiple vulnerabilities have been found in Konqueror, the worst of which may allow execution of arbitrary code.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 201406-31
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: Konqueror: Multiple vulnerabilities
         Date: June 27, 2014
         Bugs: #438452
           ID: 201406-31
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been found in Konqueror, the worst of
    which may allow execution of arbitrary code.
    
    Background
    ==========
    
    Konqueror is the KDE web browser and file manager.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  kde-base/konqueror          < 4.9.3-r1 >= 4.9.3-r1
    
    Description
    ===========
    
    Multiple vulnerabilities have been discovered in Konqueror. Please
    review the CVE identifiers referenced below for details.
    
    Impact
    ======
    
    A remote attacker could entice a user to open a specially crafted web
    site using Konqueror, possibly resulting in the execution of arbitrary
    code with the privileges of the process or a Denial of Service
    condition
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All Konqueror users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=kde-base/konqueror-4.9.3-r1"
    
    NOTE: This is a legacy GLSA. Updates for all affected architectures are
    available since November 11, 2012. It is likely that your system is
    already no longer affected by this issue.
    
    References
    ==========
    
    [ 1 ] CVE-2012-4512
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4512
    [ 2 ] CVE-2012-4513
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4513
    [ 3 ] CVE-2012-4514
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4514
    [ 4 ] CVE-2012-4515
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-4515
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     http://security.gentoo.org/glsa/glsa-201406-31.xml
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2014 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    http://creativecommons.org/licenses/by-sa/2.5
    
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"7","type":"x","order":"1","pct":58.33,"resources":[]},{"id":"88","title":"Should be more technical","votes":"3","type":"x","order":"2","pct":25,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"2","type":"x","order":"3","pct":16.67,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    Advisories

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.