Gentoo: GLSA-201406-36: OpenLDAP: Multiple vulnerabilities

    Date30 Jun 2014
    CategoryGentoo
    64
    Posted ByLinuxSecurity Advisories
    Multiple vulnerabilities were found in OpenLDAP, allowing for Denial of Service or a man-in-the-middle attack.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 201406-36
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: OpenLDAP: Multiple vulnerabilities
         Date: June 30, 2014
         Bugs: #290345, #323777, #355333, #388605, #407941, #424167
           ID: 201406-36
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities were found in OpenLDAP, allowing for Denial of
    Service or a man-in-the-middle attack.
    
    Background
    ==========
    
    OpenLDAP is an LDAP suite of application and development tools.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  net-nds/openldap             < 2.4.35                  >= 2.4.35
    
    Description
    ===========
    
    Multiple vulnerabilities have been discovered in OpenLDAP. Please
    review the CVE identifiers referenced below for details.
    
    Impact
    ======
    
    A remote attacker might employ a specially crafted certificate to
    conduct man-in-the-middle attacks on SSL connections made using
    OpenLDAP, bypass security restrictions or cause a Denial of Service
    condition.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All OpenLDAP users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=net-nds/openldap-2.4.35"
    
    References
    ==========
    
    [ 1 ] CVE-2009-3767
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2009-3767
    [ 2 ] CVE-2010-0211
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-0211
    [ 3 ] CVE-2010-0212
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-0212
    [ 4 ] CVE-2011-1024
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1024
    [ 5 ] CVE-2011-1025
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1025
    [ 6 ] CVE-2011-1081
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-1081
    [ 7 ] CVE-2011-4079
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2011-4079
    [ 8 ] CVE-2012-1164
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-1164
    [ 9 ] CVE-2012-2668
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2012-2668
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     http://security.gentoo.org/glsa/glsa-201406-36.xml
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2014 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    http://creativecommons.org/licenses/by-sa/2.5
    
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"67","type":"x","order":"1","pct":57.26,"resources":[]},{"id":"88","title":"Should be more technical","votes":"16","type":"x","order":"2","pct":13.68,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"34","type":"x","order":"3","pct":29.06,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.