Gentoo: GLSA-201407-05: OpenSSL: Multiple vulnerabilities

    Date27 Jul 2014
    CategoryGentoo
    40
    Posted ByLinuxSecurity Advisories
    Multiple vulnerabilities have been found in OpenSSL, possibly allowing remote attackers to execute arbitrary code.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 201407-05
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                http://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: High
        Title: OpenSSL: Multiple vulnerabilities
         Date: July 27, 2014
         Bugs: #512506
           ID: 201407-05
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been found in OpenSSL, possibly allowing
    remote attackers to execute arbitrary code.
    
    Background
    ==========
    
    OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
    (SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general
    purpose cryptography library.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  dev-libs/openssl           < 1.0.1h-r1 *>= 0.9.8z_p5
                                                            *>= 0.9.8z_p4
                                                            *>= 0.9.8z_p1
                                                            *>= 0.9.8z_p3
                                                            *>= 0.9.8z_p2
                                                               *>= 1.0.0m
                                                             >= 1.0.1h-r1
    
    Description
    ===========
    
    Multiple vulnerabilities have been discovered in OpenSSL. Please review
    the OpenSSL Security Advisory [05 Jun 2014] and the CVE identifiers
    referenced below for details.
    
    Impact
    ======
    
    A remote attacker could send specially crafted DTLS fragments to an
    OpenSSL DTLS client or server to possibly execute arbitrary code with
    the privileges of the process using OpenSSL.
    
    Furthermore, an attacker could force the use of weak keying material in
    OpenSSL SSL/TLS clients and servers, inject data across sessions, or
    cause a Denial of Service via various vectors.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All OpenSSL users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.1h-r1"
    
    References
    ==========
    
    [ 1 ] CVE-2010-5298
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2010-5298
    [ 2 ] CVE-2014-0195
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0195
    [ 3 ] CVE-2014-0198
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0198
    [ 4 ] CVE-2014-0221
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0221
    [ 5 ] CVE-2014-0224
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-0224
    [ 6 ] CVE-2014-3470
          http://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-3470
    [ 7 ] OpenSSL Security Advisory [05 Jun 2014]
          http://www.openssl.org/news/secadv_20140605.txt
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     http://security.gentoo.org/glsa/glsa-201407-05.xml
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2014 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    http://creativecommons.org/licenses/by-sa/2.5
    
    
    
    
    You are not authorised to post comments.

    Comments powered by CComment

    LinuxSecurity Poll

    What do you think of the articles on LinuxSecurity?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/24-what-do-you-think-of-the-quality-of-the-articles-on-linuxsecurity?task=poll.vote&format=json
    24
    radio
    [{"id":"87","title":"Excellent, don't change a thing!","votes":"4","type":"x","order":"1","pct":57.14,"resources":[]},{"id":"88","title":"Should be more technical","votes":"2","type":"x","order":"2","pct":28.57,"resources":[]},{"id":"89","title":"Should include more HOWTOs","votes":"1","type":"x","order":"3","pct":14.29,"resources":[]}]["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"]["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"]350
    bottom200

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.