Gentoo: GLSA-201411-02: MySQL, MariaDB: Multiple vulnerabilities

    Date 05 Nov 2014
    63
    Posted By LinuxSecurity Advisories
    Multiple vulnerabilities have been found in the MySQL and MariaDB, possibly allowing attackers to cause unspecified impact.
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    Gentoo Linux Security Advisory                           GLSA 201411-02
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                                https://security.gentoo.org/
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
     Severity: Normal
        Title: MySQL, MariaDB: Multiple vulnerabilities
         Date: November 05, 2014
         Bugs: #525504
           ID: 201411-02
    
    - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
    
    Synopsis
    ========
    
    Multiple vulnerabilities have been found in the MySQL and MariaDB,
    possibly allowing attackers to cause unspecified impact.
    
    Background
    ==========
    
    MySQL is a popular multi-threaded, multi-user SQL server. MariaDB is an
    enhanced, drop-in replacement for MySQL.
    
    Affected packages
    =================
    
        -------------------------------------------------------------------
         Package              /     Vulnerable     /            Unaffected
        -------------------------------------------------------------------
      1  dev-db/mysql                 < 5.5.40                  >= 5.5.40
      2  dev-db/mariadb             < 5.5.40-r1              >= 5.5.40-r1
        -------------------------------------------------------------------
         2 affected packages
    
    Description
    ===========
    
    Multiple unspecified vulnerabilities have been discovered in MySQL.
    Please review the CVE identifiers referenced below for details.
    
    Impact
    ======
    
    A remote attacker could exploit these vulnerabilities to cause
    unspecified impact, possibly including remote execution of arbitrary
    code, Denial of Service, or disclosure of sensitive information.
    
    Workaround
    ==========
    
    There is no known workaround at this time.
    
    Resolution
    ==========
    
    All MySQL users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/mysql-5.5.40"
    
    All MariaDB users should upgrade to the latest version:
    
      # emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-db/mariadb-5.5.40-r1"
    
    References
    ==========
    
    [ 1 ] CVE-2014-6464
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-6464
    [ 2 ] CVE-2014-6469
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-6469
    [ 3 ] CVE-2014-6491
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-6491
    [ 4 ] CVE-2014-6494
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-6494
    [ 5 ] CVE-2014-6496
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-6496
    [ 6 ] CVE-2014-6500
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-6500
    [ 7 ] CVE-2014-6507
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-6507
    [ 8 ] CVE-2014-6555
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-6555
    [ 9 ] CVE-2014-6559
          https://nvd.nist.gov/nvd.cfm?cvename=CVE-2014-6559
    
    Availability
    ============
    
    This GLSA and any updates to it are available for viewing at
    the Gentoo Security Website:
    
     https://security.gentoo.org/glsa/glsa-201411-02.xml
    
    Concerns?
    =========
    
    Security is a primary focus of Gentoo Linux and ensuring the
    confidentiality and security of our users' machines is of utmost
    importance to us. Any security concerns should be addressed to
    This email address is being protected from spambots. You need JavaScript enabled to view it. or alternatively, you may file a bug at
    https://bugs.gentoo.org.
    
    License
    =======
    
    Copyright 2014 Gentoo Foundation, Inc; referenced text
    belongs to its owner(s).
    
    The contents of this document are licensed under the
    Creative Commons - Attribution / Share Alike license.
    
    https://creativecommons.org/licenses/by-sa/2.5
    
    

    LinuxSecurity Poll

    Are you considering making the switch to Purism's new Librem 14 Linux laptop to improve your security and privacy online?

    No answer selected. Please try again.
    Please select either existing option or enter your own, however not both.
    Please select minimum 0 answer(s) and maximum 3 answer(s).
    /main-polls/31-are-you-considering-making-the-switch-to-purism-s-new-librem-14-linux-laptop-to-improve-your-security-and-privacy-online?task=poll.vote&format=json
    31
    radio
    [{"id":"109","title":"Yes - the hardware kill switches and default ad blocking\/tracking protection sold me on it.","votes":"2","type":"x","order":"1","pct":40,"resources":[]},{"id":"110","title":"Not sure yet - I need to do more research.","votes":"2","type":"x","order":"2","pct":40,"resources":[]},{"id":"111","title":"No - I'm satisfied with my current laptop and have no security\/privacy concerns.","votes":"1","type":"x","order":"3","pct":20,"resources":[]}] ["#ff5b00","#4ac0f2","#b80028","#eef66c","#60bb22","#b96a9a","#62c2cc"] ["rgba(255,91,0,0.7)","rgba(74,192,242,0.7)","rgba(184,0,40,0.7)","rgba(238,246,108,0.7)","rgba(96,187,34,0.7)","rgba(185,106,154,0.7)","rgba(98,194,204,0.7)"] 350
    bottom 200

    Please enable / Bitte aktiviere JavaScript!
    Veuillez activer / Por favor activa el Javascript![ ? ]

    We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.