- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202011-14
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                           https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

 Severity: High
    Title: MariaDB: Remote code execution
     Date: November 11, 2020
     Bugs: #747166
       ID: 202011-14

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

A vulnerability has been discovered in MariaDB which could result in
the arbitrary execution of code.

Background
==========

MariaDB is an enhanced, drop-in replacement for MySQL.

Affected packages
=================

    -------------------------------------------------------------------
     Package              /     Vulnerable     /            Unaffected
    -------------------------------------------------------------------
  1  dev-db/mariadb               < 10.5.6             >= 10.5.6:10.5
                                                   >= 10.4.13-r3:10.4
                                                   >= 10.3.23-r3:10.3
                                                   >= 10.2.22-r3:10.2

Description
===========

It was discovered that MariaDB did not properly validate the content of
a packet received from a server.

Impact
======

A remote attacker could send a specially crafted packet to WSREP
service, possibly resulting in execution of arbitrary code with the
privileges of the process or a Denial of Service condition.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All MariaDB 10.5.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/mariadb-10.5.6:10.5"

All MariaDB 10.4.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/mariadb-10.4.13-r3:10.4"

All MariaDB 10.3.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/mariadb-10.3.23-r3:10.3"

All MariaDB 10.2.x users should upgrade to the latest version:

  # emerge --sync
  # emerge --ask --oneshot --verbose ">=dev-db/mariadb-10.2.22-r3:10.2"

References
==========

[ 1 ] CVE-2020-15180
      https://nvd.nist.gov/vuln/detail/CVE-2020-15180

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

 https://security.gentoo.org/glsa/202011-14

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5