- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 202012-07
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            https://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: PostgreSQL: Multiple vulnerabilities
      Date: December 07, 2020
      Bugs: #754363
        ID: 202012-07

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Multiple vulnerabilities have been found in PostgreSQL, the worst of
which could result in arbitrary code execution.

Background
==========

PostgreSQL is an open source object-relational database management
system.

Affected packages
=================

     -------------------------------------------------------------------
      Package              /     Vulnerable     /            Unaffected
     -------------------------------------------------------------------
   1  dev-db/postgresql             < 13.1               >= 9.5.24:9.5
                                                         >= 9.6.20:9.6
                                                           >= 10.15:10
                                                           >= 11.10:11
                                                            >= 12.5:12
                                                            >= 13.1:13

Description
===========

Multiple vulnerabilities have been discovered in PostgreSQL. Please
review the CVE identifiers referenced below for details.

Impact
======

A remote attacker could possibly obtain sensitive information, alter
SQL commands, escape PostgreSQL sandbox or execute arbitrary code with
the privileges of the process.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All PostgreSQL 9.5.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.5.24:9.5"

All PostgreSQL 9.6.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-db/postgresql-9.6.20:9.6"

All PostgreSQL 10.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-db/postgresql-10.15:10"

All PostgreSQL 11.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-db/postgresql-11.10:11"

All PostgreSQL 12.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-db/postgresql-12.5:12"

All PostgreSQL 13.x users should upgrade to the latest version:

   # emerge --sync
   # emerge --ask --oneshot --verbose ">=dev-db/postgresql-13.1:13"

References
==========

[ 1 ] CVE-2020-25694
       https://nvd.nist.gov/vuln/detail/CVE-2020-25694
[ 2 ] CVE-2020-25695
       https://nvd.nist.gov/vuln/detail/CVE-2020-25695
[ 3 ] CVE-2020-25696
       https://nvd.nist.gov/vuln/detail/CVE-2020-25696

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  https://security.gentoo.org/glsa/202012-07

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users' machines is of utmost
importance to us. Any security concerns should be addressed to
[email protected] or alternatively, you may file a bug at
https://bugs.gentoo.org.

License
=======

Copyright 2020 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

https://creativecommons.org/licenses/by-sa/2.5