MGASA-2020-0424 - Updated golang packages fix a security vulnerability

Publication date: 15 Nov 2020
URL: https://advisories.mageia.org/MGASA-2020-0424.html
Type: security
Affected Mageia releases: 7
CVE: CVE-2020-24553

A flaw was found in Go standard library packages. Both the net/http/cgi and
net/http/fcgi packages use a default Content-Type response header value of
"text/html", rather than "text/plain". An attacker could exploit this in
applications using these packages by uploading crafted files, allowing for a
cross-site scripting attack (XSS) (CVE-2020-24553).

References:
- https://bugs.mageia.org/show_bug.cgi?id=27324
- https://lists.fedoraproject.org/archives/list/[email protected]/thread/CZBO7Q73GGWBVYIKNH2HNN44Q5IQND5W/
- https://lists.opensuse.org/opensuse-security-announce/2020-10/msg00002.html
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2020-24553

SRPMS:
- 7/core/golang-1.13.15-2.mga7