MGASA-2021-0428 - Updated apr packages fix security vulnerability

Publication date: 23 Sep 2021
URL: https://advisories.mageia.org/MGASA-2021-0428.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2021-35940

An out-of-bounds array read in the apr_time_exp*() functions was fixed in
the Apache Portable Runtime 1.6.3 release (CVE-2017-12613). The fix for
this issue was not carried forward to the APR 1.7.x branch, and hence
version 1.7.0 regressed compared to 1.6.3 and is vulnerable to the same
issue. (CVE-2021-35940)

References:
- https://bugs.mageia.org/show_bug.cgi?id=29400
- https://www.openwall.com/lists/oss-security/2021/08/23/1
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2021-35940

SRPMS:
- 8/core/apr-1.7.0-3.2.mga8