Mageia 2022-0409: expat security update | LinuxSecurity.com
MGASA-2022-0409 - Updated expat packages fix security vulnerability

Publication date: 04 Nov 2022
URL: https://advisories.mageia.org/MGASA-2022-0409.html
Type: security
Affected Mageia releases: 8
CVE: CVE-2022-43680

In libexpat through 2.4.9, there is a use-after free caused by overeager
destruction of a shared DTD in XML_ExternalEntityParserCreate in
out-of-memory situations. (CVE-2022-43680)

References:
- https://bugs.mageia.org/show_bug.cgi?id=31057
- https://www.debian.org/security/2022/dsa-5266
- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-43680

SRPMS:
- 8/core/expat-2.2.10-1.6.mga8

Mageia 2022-0409: expat security update

In libexpat through 2.4.9, there is a use-after free caused by overeager destruction of a shared DTD in XML_ExternalEntityParserCreate in out-of-memory situations

Summary

In libexpat through 2.4.9, there is a use-after free caused by overeager destruction of a shared DTD in XML_ExternalEntityParserCreate in out-of-memory situations. (CVE-2022-43680)

References

- https://bugs.mageia.org/show_bug.cgi?id=31057

- https://www.debian.org/security/2022/dsa-5266

- https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-43680

Resolution

MGASA-2022-0409 - Updated expat packages fix security vulnerability

SRPMS

- 8/core/expat-2.2.10-1.6.mga8

Severity
Publication date: 04 Nov 2022
URL: https://advisories.mageia.org/MGASA-2022-0409.html
Type: security
CVE: CVE-2022-43680

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.