openSUSE Security Update: Security update for pam_radius
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:0870-1
Rating:             moderate
References:         #1163933 
Cross-References:   CVE-2015-9542
CVSS scores:
                    CVE-2015-9542 (NVD) : 7.5 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
                    CVE-2015-9542 (SUSE): 6.5 CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes one vulnerability is now available.

Description:

   This update for pam_radius fixes the following issues:

   - CVE-2015-9542: pam_radius: buffer overflow in password field
     (bsc#1163933)

   This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-870=1



Package List:

   - openSUSE Leap 15.2 (i586 x86_64):

      pam_radius-1.4.0-lp152.4.3.1
      pam_radius-debuginfo-1.4.0-lp152.4.3.1
      pam_radius-debugsource-1.4.0-lp152.4.3.1

   - openSUSE Leap 15.2 (x86_64):

      pam_radius-32bit-1.4.0-lp152.4.3.1
      pam_radius-32bit-debuginfo-1.4.0-lp152.4.3.1


References:

   https://www.suse.com/security/cve/CVE-2015-9542.html
   https://bugzilla.suse.com/1163933