openSUSE Security Update: Security update for apache2-mod_auth_openidc
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:1277-1
Rating:             moderate
References:         #1188638 #1188639 #1188848 #1188849 
Cross-References:   CVE-2021-32785 CVE-2021-32786 CVE-2021-32791
                    CVE-2021-32792
CVSS scores:
                    CVE-2021-32785 (SUSE): 5.3 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L
                    CVE-2021-32786 (SUSE): 4.7 CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:L/A:N
                    CVE-2021-32791 (SUSE): 5.9 CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N
                    CVE-2021-32792 (SUSE): 3.1 CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:L/I:N/A:N

Affected Products:
                    openSUSE Leap 15.2
______________________________________________________________________________

   An update that fixes four vulnerabilities is now available.

Description:

   This update for apache2-mod_auth_openidc fixes the following issues:

   - CVE-2021-32785: format string bug via hiredis (bsc#1188638)
   - CVE-2021-32786: open redirect in logout functionality (bsc#1188639)
   - CVE-2021-32791: Hardcoded static IV and AAD with a reused key in AES GCM
     encryption (bsc#1188849)
   - CVE-2021-32792: XSS when using OIDCPreservePost On (bsc#1188848)

   This update was imported from the SUSE:SLE-15-SP1:Update update project.


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.2:

      zypper in -t patch openSUSE-2021-1277=1



Package List:

   - openSUSE Leap 15.2 (x86_64):

      apache2-mod_auth_openidc-2.3.8-lp152.5.6.1
      apache2-mod_auth_openidc-debuginfo-2.3.8-lp152.5.6.1
      apache2-mod_auth_openidc-debugsource-2.3.8-lp152.5.6.1


References:

   https://www.suse.com/security/cve/CVE-2021-32785.html
   https://www.suse.com/security/cve/CVE-2021-32786.html
   https://www.suse.com/security/cve/CVE-2021-32791.html
   https://www.suse.com/security/cve/CVE-2021-32792.html
   https://bugzilla.suse.com/1188638
   https://bugzilla.suse.com/1188639
   https://bugzilla.suse.com/1188848
   https://bugzilla.suse.com/1188849