openSUSE Security Update: Security update for ghostscript
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2021:3044-1
Rating:             critical
References:         #1184123 #1190381 
Cross-References:   CVE-2021-3781
CVSS scores:
                    CVE-2021-3781 (SUSE): 9.8 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Affected Products:
                    openSUSE Leap 15.3
______________________________________________________________________________

   An update that solves one vulnerability and has one errata
   is now available.

Description:

   This update for ghostscript fixes the following issues:

   Security issue fixed:

   - CVE-2021-3781: Fixed a trivial -dSAFER bypass command injection
     (bsc#1190381)

   Also a hardening fix was added:

   - Link as position independent executable (bsc#1184123)


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Leap 15.3:

      zypper in -t patch openSUSE-SLE-15.3-2021-3044=1



Package List:

   - openSUSE Leap 15.3 (aarch64 ppc64le s390x x86_64):

      ghostscript-9.52-155.1
      ghostscript-debuginfo-9.52-155.1
      ghostscript-debugsource-9.52-155.1
      ghostscript-devel-9.52-155.1
      ghostscript-x11-9.52-155.1
      ghostscript-x11-debuginfo-9.52-155.1
      libspectre-debugsource-0.2.8-3.12.1
      libspectre-devel-0.2.8-3.12.1
      libspectre1-0.2.8-3.12.1
      libspectre1-debuginfo-0.2.8-3.12.1


References:

   https://www.suse.com/security/cve/CVE-2021-3781.html
   https://bugzilla.suse.com/1184123
   https://bugzilla.suse.com/1190381