openSUSE: 2022:10247-1 important: mbedtls | LinuxSecurity.com

   openSUSE Security Update: Security update for mbedtls
______________________________________________________________________________

Announcement ID:    openSUSE-SU-2022:10247-1
Rating:             important
References:         #1201581 
Cross-References:   CVE-2021-35409 CVE-2022-35409
CVSS scores:
                    CVE-2022-35409 (NVD) : 9.1 CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H

Affected Products:
                    openSUSE Backports SLE-15-SP3
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for mbedtls fixes the following issues:

   - CVE-2022-35409: Fixed buffer overread in DTLS ClientHello parsing
     (boo#1201581).


Patch Instructions:

   To install this openSUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - openSUSE Backports SLE-15-SP3:

      zypper in -t patch openSUSE-2022-10247=1



Package List:

   - openSUSE Backports SLE-15-SP3 (aarch64 i586 ppc64le s390x x86_64):

      libmbedcrypto3-2.16.9-bp153.2.8.1
      libmbedtls12-2.16.9-bp153.2.8.1
      libmbedx509-0-2.16.9-bp153.2.8.1
      mbedtls-devel-2.16.9-bp153.2.8.1

   - openSUSE Backports SLE-15-SP3 (aarch64_ilp32):

      libmbedcrypto3-64bit-2.16.9-bp153.2.8.1
      libmbedtls12-64bit-2.16.9-bp153.2.8.1
      libmbedx509-0-64bit-2.16.9-bp153.2.8.1

   - openSUSE Backports SLE-15-SP3 (x86_64):

      libmbedcrypto3-32bit-2.16.9-bp153.2.8.1
      libmbedtls12-32bit-2.16.9-bp153.2.8.1
      libmbedx509-0-32bit-2.16.9-bp153.2.8.1


References:

   https://www.suse.com/security/cve/CVE-2021-35409.html
   https://www.suse.com/security/cve/CVE-2022-35409.html
   https://bugzilla.suse.com/1201581

openSUSE: 2022:10247-1 important: mbedtls

December 22, 2022
An update that fixes two vulnerabilities is now available

Description

This update for mbedtls fixes the following issues: - CVE-2022-35409: Fixed buffer overread in DTLS ClientHello parsing (boo#1201581).

 

Patch

Patch Instructions: To install this openSUSE Security Update use the SUSE recommended installation methods like YaST online_update or "zypper patch". Alternatively you can run the command listed for your product: - openSUSE Backports SLE-15-SP3: zypper in -t patch openSUSE-2022-10247=1


Package List

- openSUSE Backports SLE-15-SP3 (aarch64 i586 ppc64le s390x x86_64): libmbedcrypto3-2.16.9-bp153.2.8.1 libmbedtls12-2.16.9-bp153.2.8.1 libmbedx509-0-2.16.9-bp153.2.8.1 mbedtls-devel-2.16.9-bp153.2.8.1 - openSUSE Backports SLE-15-SP3 (aarch64_ilp32): libmbedcrypto3-64bit-2.16.9-bp153.2.8.1 libmbedtls12-64bit-2.16.9-bp153.2.8.1 libmbedx509-0-64bit-2.16.9-bp153.2.8.1 - openSUSE Backports SLE-15-SP3 (x86_64): libmbedcrypto3-32bit-2.16.9-bp153.2.8.1 libmbedtls12-32bit-2.16.9-bp153.2.8.1 libmbedx509-0-32bit-2.16.9-bp153.2.8.1


References

https://www.suse.com/security/cve/CVE-2021-35409.html https://www.suse.com/security/cve/CVE-2022-35409.html https://bugzilla.suse.com/1201581


Severity
Announcement ID: openSUSE-SU-2022:10247-1
Rating: important
Affected Products: openSUSE Backports SLE-15-SP3 .

Related News

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.