Oracle Linux Security Advisory ELSA-2021-3798

https://linux.oracle.com/errata/ELSA-2021-3798.html

The following updated rpms for Oracle Linux 7 have been uploaded to the Unbreakable Linux Network:

x86_64:
openssl-1.0.2k-22.el7_9.x86_64.rpm
openssl-devel-1.0.2k-22.el7_9.i686.rpm
openssl-devel-1.0.2k-22.el7_9.x86_64.rpm
openssl-libs-1.0.2k-22.el7_9.i686.rpm
openssl-libs-1.0.2k-22.el7_9.x86_64.rpm
openssl-perl-1.0.2k-22.el7_9.x86_64.rpm
openssl-static-1.0.2k-22.el7_9.i686.rpm
openssl-static-1.0.2k-22.el7_9.x86_64.rpm


SRPMS:
https://oss.oracle.com/ol7/SRPMS-updates/openssl-1.0.2k-22.el7_9.src.rpm

Related CVEs:

CVE-2021-23840
CVE-2021-23841




Description of changes:

[1.0.2k-22]
- fix CVE-2021-23841 openssl: NULL pointer dereference
  in X509_issuer_and_serial_hash()
- fix CVE-2021-23840 openssl: integer overflow in CipherUpdate
- Resolves: rhbz#1932132, rhbz#1932126


_______________________________________________
El-errata mailing list
[email protected]
https://oss.oracle.com/mailman/listinfo/el-errata