RedHat: RHSA-2022-2214:01 Important: zlib security update | LinuxSe...
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: zlib security update
Advisory ID:       RHSA-2022:2214-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2022:2214
Issue date:        2022-05-11
CVE Names:         CVE-2018-25032 
=====================================================================

1. Summary:

An update for zlib is now available for Red Hat Enterprise Linux 6 Extended
Lifecycle Support.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Server (v. 6 ELS) - i386, s390x, x86_64
Red Hat Enterprise Linux Server Optional (v. 6 ELS) - i386, s390x, x86_64

3. Description:

The zlib packages provide a general-purpose lossless data compression
library that is used by many different programs.

Security Fix(es):

* zlib: A flaw found in zlib when compressing (not decompressing) certain
inputs (CVE-2018-25032)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

2067945 - CVE-2018-25032 zlib: A flaw found in zlib when compressing (not decompressing) certain inputs

6. Package List:

Red Hat Enterprise Linux Server (v. 6 ELS):

Source:
zlib-1.2.3-31.el6_10.src.rpm

i386:
zlib-1.2.3-31.el6_10.i686.rpm
zlib-debuginfo-1.2.3-31.el6_10.i686.rpm
zlib-devel-1.2.3-31.el6_10.i686.rpm

s390x:
zlib-1.2.3-31.el6_10.s390.rpm
zlib-1.2.3-31.el6_10.s390x.rpm
zlib-debuginfo-1.2.3-31.el6_10.s390.rpm
zlib-debuginfo-1.2.3-31.el6_10.s390x.rpm
zlib-devel-1.2.3-31.el6_10.s390.rpm
zlib-devel-1.2.3-31.el6_10.s390x.rpm

x86_64:
zlib-1.2.3-31.el6_10.i686.rpm
zlib-1.2.3-31.el6_10.x86_64.rpm
zlib-debuginfo-1.2.3-31.el6_10.i686.rpm
zlib-debuginfo-1.2.3-31.el6_10.x86_64.rpm
zlib-devel-1.2.3-31.el6_10.i686.rpm
zlib-devel-1.2.3-31.el6_10.x86_64.rpm

Red Hat Enterprise Linux Server Optional (v. 6 ELS):

i386:
minizip-1.2.3-31.el6_10.i686.rpm
minizip-devel-1.2.3-31.el6_10.i686.rpm
zlib-debuginfo-1.2.3-31.el6_10.i686.rpm
zlib-static-1.2.3-31.el6_10.i686.rpm

s390x:
minizip-1.2.3-31.el6_10.s390.rpm
minizip-1.2.3-31.el6_10.s390x.rpm
minizip-devel-1.2.3-31.el6_10.s390.rpm
minizip-devel-1.2.3-31.el6_10.s390x.rpm
zlib-debuginfo-1.2.3-31.el6_10.s390.rpm
zlib-debuginfo-1.2.3-31.el6_10.s390x.rpm
zlib-static-1.2.3-31.el6_10.s390x.rpm

x86_64:
minizip-1.2.3-31.el6_10.i686.rpm
minizip-1.2.3-31.el6_10.x86_64.rpm
minizip-devel-1.2.3-31.el6_10.i686.rpm
minizip-devel-1.2.3-31.el6_10.x86_64.rpm
zlib-debuginfo-1.2.3-31.el6_10.i686.rpm
zlib-debuginfo-1.2.3-31.el6_10.x86_64.rpm
zlib-static-1.2.3-31.el6_10.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2018-25032
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2022 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBYnw2BtzjgjWX9erEAQjeZA//U4fM7CbjmjEFlSLiLXkxAg/vA4OddfmK
LbxlKPr0/l6bPXg/5kp1fTlTitW3dwNBwbciGMEUoELht8nCqp/6jW39sKaOztAZ
vw+IPoJ3BvnVV4768MnfMCApM/iPEPE+vP0U8fEtptNrIjQUvNX4mSX5ROyOv2HF
hbFuz3d46IT52bwbVaN5bUaCruefvWPrTsuvQ82QjMykd0TL8P7UTnCJfi9QK9fY
zO+J/3+sJ4HLoPchM613MHpRgUYIRRxIBy7N5CUdo1iKqibkye05LcAxGHKHEiZq
2OM2/UKVjIA1DOZ3Z4dYkQx86LM2IrpeELqw5vDAPk+2wexQOtcSNurs1W/No2GX
y7DkniocnCTrePRQjXF4E2rnDkbEYvK1NkCI+whb28xh8mETBiIrNqUSK2YdxrEq
jjICJAEwcjhu14SNuFWvB7767mx38xhRIT+AdM80KJ7g/EWVS1bUpsFKczaGR6F0
T6s2BeFulSdwP8eN20xjWtweQFzzdW4rmUXFhukFDCHhtdxxjMQaSpSVQbaCr0Vs
D9ja84s9UcLSfcUBHKL2YlsZSJcxfq/8M6cncb/z0Iymsa+2dzwPX5wNCUxhHVNm
E5NeH+upigtPr3i6T58SEuqe0aTGTsjt3232bWdI8Mqa9ugGcCSFex8s5IDUT2sh
vOofk4lw2SM=
=U7km
-----END PGP SIGNATURE-----
--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2022-2214:01 Important: zlib security update

An update for zlib is now available for Red Hat Enterprise Linux 6 Extended Lifecycle Support

Summary

The zlib packages provide a general-purpose lossless data compression library that is used by many different programs.
Security Fix(es):
* zlib: A flaw found in zlib when compressing (not decompressing) certain inputs (CVE-2018-25032)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution

For details on how to apply this update, which includes the changesdescribed in this advisory, refer to:https://access.redhat.com/articles/11258

References

https://access.redhat.com/security/cve/CVE-2018-25032 https://access.redhat.com/security/updates/classification/#important

Package List

Red Hat Enterprise Linux Server (v. 6 ELS):
Source: zlib-1.2.3-31.el6_10.src.rpm
i386: zlib-1.2.3-31.el6_10.i686.rpm zlib-debuginfo-1.2.3-31.el6_10.i686.rpm zlib-devel-1.2.3-31.el6_10.i686.rpm
s390x: zlib-1.2.3-31.el6_10.s390.rpm zlib-1.2.3-31.el6_10.s390x.rpm zlib-debuginfo-1.2.3-31.el6_10.s390.rpm zlib-debuginfo-1.2.3-31.el6_10.s390x.rpm zlib-devel-1.2.3-31.el6_10.s390.rpm zlib-devel-1.2.3-31.el6_10.s390x.rpm
x86_64: zlib-1.2.3-31.el6_10.i686.rpm zlib-1.2.3-31.el6_10.x86_64.rpm zlib-debuginfo-1.2.3-31.el6_10.i686.rpm zlib-debuginfo-1.2.3-31.el6_10.x86_64.rpm zlib-devel-1.2.3-31.el6_10.i686.rpm zlib-devel-1.2.3-31.el6_10.x86_64.rpm
Red Hat Enterprise Linux Server Optional (v. 6 ELS):
i386: minizip-1.2.3-31.el6_10.i686.rpm minizip-devel-1.2.3-31.el6_10.i686.rpm zlib-debuginfo-1.2.3-31.el6_10.i686.rpm zlib-static-1.2.3-31.el6_10.i686.rpm
s390x: minizip-1.2.3-31.el6_10.s390.rpm minizip-1.2.3-31.el6_10.s390x.rpm minizip-devel-1.2.3-31.el6_10.s390.rpm minizip-devel-1.2.3-31.el6_10.s390x.rpm zlib-debuginfo-1.2.3-31.el6_10.s390.rpm zlib-debuginfo-1.2.3-31.el6_10.s390x.rpm zlib-static-1.2.3-31.el6_10.s390x.rpm
x86_64: minizip-1.2.3-31.el6_10.i686.rpm minizip-1.2.3-31.el6_10.x86_64.rpm minizip-devel-1.2.3-31.el6_10.i686.rpm minizip-devel-1.2.3-31.el6_10.x86_64.rpm zlib-debuginfo-1.2.3-31.el6_10.i686.rpm zlib-debuginfo-1.2.3-31.el6_10.x86_64.rpm zlib-static-1.2.3-31.el6_10.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/

Severity
Advisory ID: RHSA-2022:2214-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2022:2214
Issued Date: : 2022-05-11
CVE Names: CVE-2018-25032

Topic

An update for zlib is now available for Red Hat Enterprise Linux 6 ExtendedLifecycle Support.Red Hat Product Security has rated this update as having a security impactof Important. A Common Vulnerability Scoring System (CVSS) base score,which gives a detailed severity rating, is available for each vulnerabilityfrom the CVE link(s) in the References section.

Relevant Releases Architectures

Red Hat Enterprise Linux Server (v. 6 ELS) - i386, s390x, x86_64

Red Hat Enterprise Linux Server Optional (v. 6 ELS) - i386, s390x, x86_64

Bugs Fixed

2067945 - CVE-2018-25032 zlib: A flaw found in zlib when compressing (not decompressing) certain inputs

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.