RedHat: RHSA-2022-6967:01 Important: compat-expat1 security update ...
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: compat-expat1 security update
Advisory ID:       RHSA-2022:6967-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2022:6967
Issue date:        2022-10-17
CVE Names:         CVE-2022-40674 
=====================================================================

1. Summary:

An update for compat-expat1 is now available for Red Hat Enterprise Linux 6
Extended Lifecycle Support.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux Server (v. 6 ELS) - i386, s390x, x86_64

3. Description:

Expat is a C library for parsing XML documents.

Security Fix(es):

* expat: a use-after-free in the doContent function in xmlparse.c
(CVE-2022-40674)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

5. Bugs fixed (https://bugzilla.redhat.com/):

2130769 - CVE-2022-40674 expat: a use-after-free in the doContent function in xmlparse.c

6. Package List:

Red Hat Enterprise Linux Server (v. 6 ELS):

Source:
compat-expat1-1.95.8-9.el6_10.src.rpm

i386:
compat-expat1-1.95.8-9.el6_10.i686.rpm
compat-expat1-debuginfo-1.95.8-9.el6_10.i686.rpm

s390x:
compat-expat1-1.95.8-9.el6_10.s390.rpm
compat-expat1-1.95.8-9.el6_10.s390x.rpm
compat-expat1-debuginfo-1.95.8-9.el6_10.s390.rpm
compat-expat1-debuginfo-1.95.8-9.el6_10.s390x.rpm

x86_64:
compat-expat1-1.95.8-9.el6_10.i686.rpm
compat-expat1-1.95.8-9.el6_10.x86_64.rpm
compat-expat1-debuginfo-1.95.8-9.el6_10.i686.rpm
compat-expat1-debuginfo-1.95.8-9.el6_10.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2022-40674
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2022 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIVAwUBY01tGdzjgjWX9erEAQj4BA/+Pj+tNylhHbtsXCUw5OjH8R9mVt0pPUNa
ITwQFgwJEdijGdRirjC4SjOHArzM6t+vNRPMZu4KWW2TGwmfkKcBf+grhxbm36E6
TS7y7S2eKpwXcD2O9YtGZJO993/vkhWJrx5GILgDsBjK/FpKNM7JdaCcnu5Tiusb
jYP7R7horqMYwst5C3K4W+7toTE05JTR/whPvoke+Q6dVx+ZKm5KQV7a1Xo/jPrL
tQuhxrRZIAFCYidNPuP0eDxpFvvb+KDCCuTcHYqRgzElbS2YsXXnT9VGFRRjfKjW
7vw6PMuSR5flOunzOxOE+FnXnqbD9cO9yCIl3dGGyFUsgTlztOfcuw4b9aBCNE5E
2rZkSTcu52VzwKGyN4wPBdEw3utxK+7uTJFn9KOfAy1xef6MYa9+lSWtQiBS7m2E
0au5mNbi61+cjgD2fV49CaQzKa1WBmVu/pyH7Is6upNU1Ojhz4ag4Kfs+BXC3dw4
Hm9CwElknXh10mR+5lycEoxI9Xm19x7GefBLvdJf8tFrAr79eScX1g2sXDnaV/hM
j6lPJnz6U+nD3c8AJsgLhdRStUnwYd8AtAdqJlkI1JTrEqI9/1lHHda3IH8p3EDj
Ah/fBeiNwD20jtJulVItDIvvVkroE6hcNNiclcP6SFn7+T4gP/juPL8i58nwJemy
DhgIuY5pxkU=
=zNn/
-----END PGP SIGNATURE-----
--
RHSA-announce mailing list
[email protected]
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2022-6967:01 Important: compat-expat1 security update

An update for compat-expat1 is now available for Red Hat Enterprise Linux 6 Extended Lifecycle Support

Summary

Expat is a C library for parsing XML documents.
Security Fix(es):
* expat: a use-after-free in the doContent function in xmlparse.c (CVE-2022-40674)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

Solution

For details on how to apply this update, which includes the changesdescribed in this advisory, refer to:https://access.redhat.com/articles/11258

References

https://access.redhat.com/security/cve/CVE-2022-40674 https://access.redhat.com/security/updates/classification/#important

Package List

Red Hat Enterprise Linux Server (v. 6 ELS):
Source: compat-expat1-1.95.8-9.el6_10.src.rpm
i386: compat-expat1-1.95.8-9.el6_10.i686.rpm compat-expat1-debuginfo-1.95.8-9.el6_10.i686.rpm
s390x: compat-expat1-1.95.8-9.el6_10.s390.rpm compat-expat1-1.95.8-9.el6_10.s390x.rpm compat-expat1-debuginfo-1.95.8-9.el6_10.s390.rpm compat-expat1-debuginfo-1.95.8-9.el6_10.s390x.rpm
x86_64: compat-expat1-1.95.8-9.el6_10.i686.rpm compat-expat1-1.95.8-9.el6_10.x86_64.rpm compat-expat1-debuginfo-1.95.8-9.el6_10.i686.rpm compat-expat1-debuginfo-1.95.8-9.el6_10.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/

Severity
Advisory ID: RHSA-2022:6967-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2022:6967
Issued Date: : 2022-10-17
CVE Names: CVE-2022-40674

Topic

An update for compat-expat1 is now available for Red Hat Enterprise Linux 6Extended Lifecycle Support.Red Hat Product Security has rated this update as having a security impactof Important. A Common Vulnerability Scoring System (CVSS) base score,which gives a detailed severity rating, is available for each vulnerabilityfrom the CVE link(s) in the References section.

Relevant Releases Architectures

Red Hat Enterprise Linux Server (v. 6 ELS) - i386, s390x, x86_64

Bugs Fixed

2130769 - CVE-2022-40674 expat: a use-after-free in the doContent function in xmlparse.c

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.