-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: firefox security update
Advisory ID:       RHSA-2023:5427-01
Product:           Red Hat Enterprise Linux
Advisory URL:      https://access.redhat.com/errata/RHSA-2023:5427
Issue date:        2023-10-04
CVE Names:         CVE-2023-3600 CVE-2023-5169 CVE-2023-5171 
                   CVE-2023-5176 CVE-2023-5217 
=====================================================================

1. Summary:

An update for firefox is now available for Red Hat Enterprise Linux 9.0
Extended Update Support.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Relevant releases/architectures:

Red Hat Enterprise Linux AppStream EUS (v.9.0) - aarch64, ppc64le, s390x, x86_64

3. Description:

Mozilla Firefox is an open-source web browser, designed for standards
compliance, performance, and portability.

This update upgrades Firefox to version 115.3.1 ESR.

Security Fix(es):

* firefox: use-after-free in workers (CVE-2023-3600)

* Mozilla: Out-of-bounds write in PathOps (CVE-2023-5169)

* Mozilla: Use-after-free in Ion Compiler (CVE-2023-5171)

* Mozilla: Memory safety bugs fixed in Firefox 118, Firefox ESR 115.3, and
Thunderbird 115.3 (CVE-2023-5176)

* libvpx: Heap buffer overflow in vp8 encoding in libvpx (CVE-2023-5217)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

4. Solution:

For details on how to apply this update, which includes the changes
described in this advisory, refer to:

https://access.redhat.com/articles/11258

After installing the update, Firefox must be restarted for the changes to
take effect.

5. Bugs fixed (https://bugzilla.redhat.com/):

2222652 - CVE-2023-3600 firefox: use-after-free in workers
2240893 - CVE-2023-5169 Mozilla: Out-of-bounds write in PathOps
2240894 - CVE-2023-5171 Mozilla: Use-after-free in Ion Compiler
2240896 - CVE-2023-5176 Mozilla: Memory safety bugs fixed in Firefox 118, Firefox ESR 115.3, and Thunderbird 115.3
2241191 - CVE-2023-5217 libvpx: Heap buffer overflow in vp8 encoding in libvpx

6. Package List:

Red Hat Enterprise Linux AppStream EUS (v.9.0):

Source:
firefox-115.3.1-1.el9_0.src.rpm

aarch64:
firefox-115.3.1-1.el9_0.aarch64.rpm
firefox-debuginfo-115.3.1-1.el9_0.aarch64.rpm
firefox-debugsource-115.3.1-1.el9_0.aarch64.rpm

ppc64le:
firefox-115.3.1-1.el9_0.ppc64le.rpm
firefox-debuginfo-115.3.1-1.el9_0.ppc64le.rpm
firefox-debugsource-115.3.1-1.el9_0.ppc64le.rpm

s390x:
firefox-115.3.1-1.el9_0.s390x.rpm
firefox-debuginfo-115.3.1-1.el9_0.s390x.rpm
firefox-debugsource-115.3.1-1.el9_0.s390x.rpm

x86_64:
firefox-115.3.1-1.el9_0.x86_64.rpm
firefox-debuginfo-115.3.1-1.el9_0.x86_64.rpm
firefox-debugsource-115.3.1-1.el9_0.x86_64.rpm

These packages are GPG signed by Red Hat for security.  Our key and
details on how to verify the signature are available from
https://access.redhat.com/security/team/key/

7. References:

https://access.redhat.com/security/cve/CVE-2023-3600
https://access.redhat.com/security/cve/CVE-2023-5169
https://access.redhat.com/security/cve/CVE-2023-5171
https://access.redhat.com/security/cve/CVE-2023-5176
https://access.redhat.com/security/cve/CVE-2023-5217
https://access.redhat.com/security/updates/classification/#important

8. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2023 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCAAGBQJlHYRSAAoJENzjgjWX9erEGn0P/2kE53hl1HKYig/4cHHhi1qj
rHgbgYzOYcpsbnQHehDQnNWt8eSJLdKoyl/dQ35tQghtF4ovOdKUctSRfHJhMean
+/ZINj0IVlrZusfQxiU70sm3eNFBqn68uKGZXo3qHvm/ZiKICUN/hOwh9FSB7/f8
4dk93RLxrKv4+7iRCsakqZqOiVf1YPNONxkzBMtUfhvp1t138wbp03IRkJeuh91W
I+npvvn3tyqcC51bRpIWXlkIkJDjUrwRBpx3iNZiB+11JSCM8ErfQGyMwzJvkaTN
kUpjilmBsLV7NVKBf8FtCnCsOF5iZCd0/xGE4iY3KVBLvqf+pX7I6WqQL1iVtaT0
HBfpHJVuBoZ6Oub6pWGUYVKBlWEkTgehuZzs21DN1l5fKNo4DAh/cFAowOmhiV0+
YSSkc2NBMXTjfMAO6000qucdQ8d/ZcQcuVgIwixe9nPPuYYQKSISmPrCQhyUT4d6
FMjcT9Q3KAXMN6ZCFWYCirOZ6CDRPKefyDQzCsBIDnE73LlAbdazhUQAtBQuvpKR
+TieUuma8LfjnrKj9PUm9UE7zy8UIWl1FOOLCTid0+Lvd8hPh9x9DKMYo11llzhj
6XLTN1R18feWB4wkCpavfAmozgvM8LzoqqLV8FQpNOwJY0P+r9pwGPVJtZHrjpRo
8YM8uLeOdgOpJ/AcKMAF
=wALV
-----END PGP SIGNATURE-----
--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2023-5427:01 Important: firefox security update

An update for firefox is now available for Red Hat Enterprise Linux 9.0 Extended Update Support

Summary

Mozilla Firefox is an open-source web browser, designed for standards compliance, performance, and portability.
This update upgrades Firefox to version 115.3.1 ESR.
Security Fix(es):
* firefox: use-after-free in workers (CVE-2023-3600)
* Mozilla: Out-of-bounds write in PathOps (CVE-2023-5169)
* Mozilla: Use-after-free in Ion Compiler (CVE-2023-5171)
* Mozilla: Memory safety bugs fixed in Firefox 118, Firefox ESR 115.3, and Thunderbird 115.3 (CVE-2023-5176)
* libvpx: Heap buffer overflow in vp8 encoding in libvpx (CVE-2023-5217)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.



Summary


Solution

For details on how to apply this update, which includes the changes described in this advisory, refer to:
https://access.redhat.com/articles/11258
After installing the update, Firefox must be restarted for the changes to take effect.

References

https://access.redhat.com/security/cve/CVE-2023-3600 https://access.redhat.com/security/cve/CVE-2023-5169 https://access.redhat.com/security/cve/CVE-2023-5171 https://access.redhat.com/security/cve/CVE-2023-5176 https://access.redhat.com/security/cve/CVE-2023-5217 https://access.redhat.com/security/updates/classification/#important

Package List

Red Hat Enterprise Linux AppStream EUS (v.9.0):
Source: firefox-115.3.1-1.el9_0.src.rpm
aarch64: firefox-115.3.1-1.el9_0.aarch64.rpm firefox-debuginfo-115.3.1-1.el9_0.aarch64.rpm firefox-debugsource-115.3.1-1.el9_0.aarch64.rpm
ppc64le: firefox-115.3.1-1.el9_0.ppc64le.rpm firefox-debuginfo-115.3.1-1.el9_0.ppc64le.rpm firefox-debugsource-115.3.1-1.el9_0.ppc64le.rpm
s390x: firefox-115.3.1-1.el9_0.s390x.rpm firefox-debuginfo-115.3.1-1.el9_0.s390x.rpm firefox-debugsource-115.3.1-1.el9_0.s390x.rpm
x86_64: firefox-115.3.1-1.el9_0.x86_64.rpm firefox-debuginfo-115.3.1-1.el9_0.x86_64.rpm firefox-debugsource-115.3.1-1.el9_0.x86_64.rpm
These packages are GPG signed by Red Hat for security. Our key and details on how to verify the signature are available from https://access.redhat.com/security/team/key/


Severity
Advisory ID: RHSA-2023:5427-01
Product: Red Hat Enterprise Linux
Advisory URL: https://access.redhat.com/errata/RHSA-2023:5427
Issued Date: : 2023-10-04
CVE Names: CVE-2023-3600 CVE-2023-5169 CVE-2023-5171 CVE-2023-5176 CVE-2023-5217

Topic

An update for firefox is now available for Red Hat Enterprise Linux 9.0Extended Update Support.Red Hat Product Security has rated this update as having a security impactof Important. A Common Vulnerability Scoring System (CVSS) base score,which gives a detailed severity rating, is available for each vulnerabilityfrom the CVE link(s) in the References section.


Topic


 

Relevant Releases Architectures

Red Hat Enterprise Linux AppStream EUS (v.9.0) - aarch64, ppc64le, s390x, x86_64


Bugs Fixed

2222652 - CVE-2023-3600 firefox: use-after-free in workers

2240893 - CVE-2023-5169 Mozilla: Out-of-bounds write in PathOps

2240894 - CVE-2023-5171 Mozilla: Use-after-free in Ion Compiler

2240896 - CVE-2023-5176 Mozilla: Memory safety bugs fixed in Firefox 118, Firefox ESR 115.3, and Thunderbird 115.3

2241191 - CVE-2023-5217 libvpx: Heap buffer overflow in vp8 encoding in libvpx


Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo