-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA256

=====================================================================
                   Red Hat Security Advisory

Synopsis:          Important: Red Hat JBoss Enterprise Application Platform 7.4.13 security update
Advisory ID:       RHSA-2023:5488-01
Product:           Red Hat JBoss Enterprise Application Platform
Advisory URL:      https://access.redhat.com/errata/RHSA-2023:5488
Issue date:        2023-10-05
CVE Names:         CVE-2022-25883 CVE-2023-3171 CVE-2023-4061 
                   CVE-2023-26136 CVE-2023-26464 CVE-2023-33201 
                   CVE-2023-34462 
=====================================================================

1. Summary:

A security update is now available for Red Hat JBoss Enterprise Application
Platform 7.4.

Red Hat Product Security has rated this update as having a security impact
of Important. A Common Vulnerability Scoring System (CVSS) base score,
which gives a detailed severity rating, is available for each vulnerability
from the CVE link(s) in the References section.

2. Description:

Red Hat JBoss Enterprise Application Platform 7 is a platform for Java
applications based on the WildFly application runtime.

This release of Red Hat JBoss Enterprise Application Platform 7.4.13 serves
as a replacement for Red Hat JBoss Enterprise Application Platform 7.4.12
and includes bug fixes and enhancements. See the Red Hat JBoss Enterprise
Application Platform 7.4.13 Release Notes for information about the most
significant bug fixes and enhancements included in this release.

Security Fix(es):

* server: eap-7: heap exhaustion via deserialization (CVE-2023-3171)

* log4j: log4j1-chainsaw, log4j1-socketappender: DoS via hashmap logging
(CVE-2023-26464)

* nodejs-semver: Regular expression denial of service (CVE-2022-25883)

* wildfly-core: Management User RBAC permission allows unexpected reading
of system-properties to an Unauthorized actor (CVE-2023-4061)

* tough-cookie: prototype pollution in cookie memstore (CVE-2023-26136)

* bouncycastle: potential blind LDAP injection attack using a self-signed
certificate (CVE-2023-33201)

* netty: netty-handler: SniHandler 16MB allocation (CVE-2023-34462)

For more details about the security issue(s), including the impact, a CVSS
score, acknowledgments, and other related information, refer to the CVE
page(s) listed in the References section.

3. Solution:

Before applying the update, back up your existing installation, including
all applications, configuration files, databases and database settings, and
so on.

The References section of this erratum contains a download link (you must
log in to download the update).

4. Bugs fixed (https://bugzilla.redhat.com/):

2182864 - CVE-2023-26464 log4j1-chainsaw, log4j1-socketappender: DoS via hashmap logging
2213639 - CVE-2023-3171 eap-7: heap exhaustion via deserialization
2215465 - CVE-2023-33201 bouncycastle: potential  blind LDAP injection attack using a self-signed certificate
2216475 - CVE-2022-25883 nodejs-semver: Regular expression denial of service
2216888 - CVE-2023-34462 netty: SniHandler 16MB allocation leads to OOM
2219310 - CVE-2023-26136 tough-cookie: prototype pollution in cookie memstore
2228608 - CVE-2023-4061 wildfly-core: Management User RBAC permission allows unexpected reading of system-properties to an Unauthorized actor

5. JIRA issues fixed (https://issues.redhat.com/):

JBEAP-24667 - (7.4.z) Upgrade Ironjacamar from 1.5.11.Final-redhat-00001 to 1.5.15.Final-redhat-00001
JBEAP-24966 - [GSS](7.4.z) Upgrade RESTEasy from 3.15.7.Final-redhat-00001 to 3.15.8.Final-redhat-00001
JBEAP-24985 - (7.4.z) Upgrade Artemis from 2.16.0.redhat-00048 to 2.16.0.redhat-00049
JBEAP-25032 - (7.4.z) Upgrade Undertow from 2.2.25.SP3-redhat-00001 to 2.2.26.SP1-redhat-00001
JBEAP-25033 - (7.4.z) Upgrade WildFly Core from 15.0.29.Final-redhat-00001 to 15.0.30.Final-redhat-00001
JBEAP-25078 - (7.4.z) Upgrade netty from 4.1.86.Final-redhat-00001 to 4.1.94.Final-redhat-00001 (resolves CVE-2023-34462)
JBEAP-25122 - (7.4.z) Upgrade jboss-marshalling from 2.0.13.Final-redhat-00001 to 2.0.13.SP1-redhat-00001
JBEAP-25135 - (7.4.z) Upgrade Elytron from 1.15.17.Final-redhat-00001 to 1.15.20.Final-redhat-00001
JBEAP-25186 - (7.4.z) Upgrade hal console from 3.3.18.Final-redhat-00001 to 3.3.19.Final-redhat-00001
JBEAP-25200 - (7.4.z) Upgrade Hibernate ORM from 5.3.30.Final-redhat-00001 to 5.3.31.Final-redhat-00001
JBEAP-25225 - (7.4.z) Upgrade mod_cluster from 1.4.4.Final-redhat-00001 to 1.4.5.Final-redhat-00001
JBEAP-25261 - (7.4.z) NettyConnection.batchBufferSize() is broken after upgrading netty to 4.1.94.Final
JBEAP-25285 - [GSS](7.4.z) Upgrade JBoss Modules from 1.12.0.Final-redhat-00001 to 1.12.2.Final-redhat-00001
JBEAP-25312 - [GSS](7.4.z) Upgrade xnio from 3.8.9.Final-redhat-00001 to 3.8.10.Final-redhat-00001

6. References:

https://access.redhat.com/security/cve/CVE-2022-25883
https://access.redhat.com/security/cve/CVE-2023-3171
https://access.redhat.com/security/cve/CVE-2023-4061
https://access.redhat.com/security/cve/CVE-2023-26136
https://access.redhat.com/security/cve/CVE-2023-26464
https://access.redhat.com/security/cve/CVE-2023-33201
https://access.redhat.com/security/cve/CVE-2023-34462
https://access.redhat.com/security/updates/classification/#important
https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?downloadType=securityPatches&product=appplatform&version=7.4
https://access.redhat.com/documentation/en-us/red_hat_jboss_enterprise_application_platform/7.4/
https://access.redhat.com/documentation/en-us/red_hat_jboss_enterprise_application_platform/7.4/html-single/installation_guide/

7. Contact:

The Red Hat security contact is . More contact
details at https://access.redhat.com/security/team/contact/

Copyright 2023 Red Hat, Inc.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1

iQIcBAEBCAAGBQJlHyouAAoJENzjgjWX9erERGwP/0NqVlWuHqwN9bWPxogHrBPy
6T86yMB1D8C5Bm0H+fRjQ+BHHatUdSeFPkawDqwzEkPS/hnQ0QcMUbrQKa2L+ZZw
E9ikiu7iA1q87+t88ljPINb/fOupi1iI7AZ166+y0CPVVQf2I6F7i+dIQW+Ieu4e
hgynRquwB5Emk5A1Z9O3koILIZk23F0N1HIkpDwOdNz7d2WyA5pumnvXrEyMYHW4
lsUtGLnAZkkYuvJk3HbzAQnfhtDrvV6FCJlHQgL74SgQDA6y5jgsJvSR7h6FWHSF
xVwSB7XMa5RIpccLhhP8HFgsbR3nQXF4uohSdIF4KTWUXABCw/7ILBdU5rwmANr7
8OL1u2xr8Ymlu2YBWBgGnfpl8q8yrqLedSKwqNojH99fTUztujQEAMCn2OCrZCDK
lJq2Cd4WzYAEJhE/elhpwzGuoi2XFrg/XskSm4T3PFYljqnEGk08aGWlUDodLXty
fhS4QLXR/aThvhzb01FcPfhejCt+KRiMFkn+35cuLoMkMO1ulyMpw4nMovNeSJsd
+wclddlYRjgL8Y+8FzgTY+tcGkdu+aGBYrFzOWRH547AsgiYFrUhDDq98pdPAaNF
GukPLpeKeHC3y+wGIZ2rujw72gUmlGmbn80HEWZoJjv7pS2qHi85dkWHulEDUHAY
02EVzdwSyAzbqSgTs2M6
=2tEW
-----END PGP SIGNATURE-----
--
RHSA-announce mailing list
RHSA-announce@redhat.com
https://listman.redhat.com/mailman/listinfo/rhsa-announce

RedHat: RHSA-2023-5488:01 Important: Red Hat JBoss Enterprise Application

A security update is now available for Red Hat JBoss Enterprise Application Platform 7.4

Summary

Red Hat JBoss Enterprise Application Platform 7 is a platform for Java applications based on the WildFly application runtime.
This release of Red Hat JBoss Enterprise Application Platform 7.4.13 serves as a replacement for Red Hat JBoss Enterprise Application Platform 7.4.12 and includes bug fixes and enhancements. See the Red Hat JBoss Enterprise Application Platform 7.4.13 Release Notes for information about the most significant bug fixes and enhancements included in this release.
Security Fix(es):
* server: eap-7: heap exhaustion via deserialization (CVE-2023-3171)
* log4j: log4j1-chainsaw, log4j1-socketappender: DoS via hashmap logging (CVE-2023-26464)
* nodejs-semver: Regular expression denial of service (CVE-2022-25883)
* wildfly-core: Management User RBAC permission allows unexpected reading of system-properties to an Unauthorized actor (CVE-2023-4061)
* tough-cookie: prototype pollution in cookie memstore (CVE-2023-26136)
* bouncycastle: potential blind LDAP injection attack using a self-signed certificate (CVE-2023-33201)
* netty: netty-handler: SniHandler 16MB allocation (CVE-2023-34462)
For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.



Summary


Solution

Before applying the update, back up your existing installation, including all applications, configuration files, databases and database settings, and so on.
The References section of this erratum contains a download link (you must log in to download the update).

References

https://access.redhat.com/security/cve/CVE-2022-25883 https://access.redhat.com/security/cve/CVE-2023-3171 https://access.redhat.com/security/cve/CVE-2023-4061 https://access.redhat.com/security/cve/CVE-2023-26136 https://access.redhat.com/security/cve/CVE-2023-26464 https://access.redhat.com/security/cve/CVE-2023-33201 https://access.redhat.com/security/cve/CVE-2023-34462 https://access.redhat.com/security/updates/classification/#important https://access.redhat.com/jbossnetwork/restricted/listSoftware.html?downloadType=securityPatches&product=appplatform&version=7.4 https://access.redhat.com/documentation/en-us/red_hat_jboss_enterprise_application_platform/7.4/ https://access.redhat.com/documentation/en-us/red_hat_jboss_enterprise_application_platform/7.4/html-single/installation_guide/

Package List


Severity
Advisory ID: RHSA-2023:5488-01
Product: Red Hat JBoss Enterprise Application Platform
Advisory URL: https://access.redhat.com/errata/RHSA-2023:5488
Issued Date: : 2023-10-05
CVE Names: CVE-2022-25883 CVE-2023-3171 CVE-2023-4061 CVE-2023-26136 CVE-2023-26464 CVE-2023-33201 CVE-2023-34462

Topic

A security update is now available for Red Hat JBoss Enterprise ApplicationPlatform 7.4.Red Hat Product Security has rated this update as having a security impactof Important. A Common Vulnerability Scoring System (CVSS) base score,which gives a detailed severity rating, is available for each vulnerabilityfrom the CVE link(s) in the References section.


Topic


 

Relevant Releases Architectures


Bugs Fixed

2182864 - CVE-2023-26464 log4j1-chainsaw, log4j1-socketappender: DoS via hashmap logging

2213639 - CVE-2023-3171 eap-7: heap exhaustion via deserialization

2215465 - CVE-2023-33201 bouncycastle: potential blind LDAP injection attack using a self-signed certificate

2216475 - CVE-2022-25883 nodejs-semver: Regular expression denial of service

2216888 - CVE-2023-34462 netty: SniHandler 16MB allocation leads to OOM

2219310 - CVE-2023-26136 tough-cookie: prototype pollution in cookie memstore

2228608 - CVE-2023-4061 wildfly-core: Management User RBAC permission allows unexpected reading of system-properties to an Unauthorized actor

5. JIRA issues fixed (https://issues.redhat.com/):

JBEAP-24667 - (7.4.z) Upgrade Ironjacamar from 1.5.11.Final-redhat-00001 to 1.5.15.Final-redhat-00001

JBEAP-24966 - [GSS](7.4.z) Upgrade RESTEasy from 3.15.7.Final-redhat-00001 to 3.15.8.Final-redhat-00001

JBEAP-24985 - (7.4.z) Upgrade Artemis from 2.16.0.redhat-00048 to 2.16.0.redhat-00049

JBEAP-25032 - (7.4.z) Upgrade Undertow from 2.2.25.SP3-redhat-00001 to 2.2.26.SP1-redhat-00001

JBEAP-25033 - (7.4.z) Upgrade WildFly Core from 15.0.29.Final-redhat-00001 to 15.0.30.Final-redhat-00001

JBEAP-25078 - (7.4.z) Upgrade netty from 4.1.86.Final-redhat-00001 to 4.1.94.Final-redhat-00001 (resolves CVE-2023-34462)

JBEAP-25122 - (7.4.z) Upgrade jboss-marshalling from 2.0.13.Final-redhat-00001 to 2.0.13.SP1-redhat-00001

JBEAP-25135 - (7.4.z) Upgrade Elytron from 1.15.17.Final-redhat-00001 to 1.15.20.Final-redhat-00001

JBEAP-25186 - (7.4.z) Upgrade hal console from 3.3.18.Final-redhat-00001 to 3.3.19.Final-redhat-00001

JBEAP-25200 - (7.4.z) Upgrade Hibernate ORM from 5.3.30.Final-redhat-00001 to 5.3.31.Final-redhat-00001

JBEAP-25225 - (7.4.z) Upgrade mod_cluster from 1.4.4.Final-redhat-00001 to 1.4.5.Final-redhat-00001

JBEAP-25261 - (7.4.z) NettyConnection.batchBufferSize() is broken after upgrading netty to 4.1.94.Final

JBEAP-25285 - [GSS](7.4.z) Upgrade JBoss Modules from 1.12.0.Final-redhat-00001 to 1.12.2.Final-redhat-00001

JBEAP-25312 - [GSS](7.4.z) Upgrade xnio from 3.8.9.Final-redhat-00001 to 3.8.10.Final-redhat-00001


Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo