{"type":"TYPE_SECURITY","shortCode":"RL","name":"RLSA-2023:4523","synopsis":"Moderate: curl security update","severity":"SEVERITY_MODERATE","topic":"An update is available for curl.\nThis update affects Rocky Linux 8.\nA Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list","description":"The curl packages provide the libcurl library and the curl utility for downloading files from servers using various protocols, including HTTP, FTP, and LDAP.\n\nSecurity Fix(es):\n\n* curl: GSS delegation too eager connection re-use (CVE-2023-27536)\n\n* curl: IDN wildcard match may lead to Improper Cerificate Validation (CVE-2023-28321)\n\nFor more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.","solution":null,"affectedProducts":["Rocky Linux 8"],"fixes":[{"ticket":"2179092","sourceBy":"Red Hat","sourceLink":"https:\/\/bugzilla.redhat.com\/show_bug.cgi?id=2179092","description":""},{"ticket":"2196786","sourceBy":"Red Hat","sourceLink":"https:\/\/bugzilla.redhat.com\/show_bug.cgi?id=2196786","description":""}],"cves":[{"name":"CVE-2023-27536","sourceBy":"MITRE","sourceLink":"https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2023-27536","cvss3ScoringVector":"CVSS:3.1\/AV:N\/AC:H\/PR:N\/UI:N\/S:U\/C:H\/I:N\/A:N","cvss3BaseScore":"5.9","cwe":"CWE-305"},{"name":"CVE-2023-28321","sourceBy":"MITRE","sourceLink":"https:\/\/cve.mitre.org\/cgi-bin\/cvename.cgi?name=CVE-2023-28321","cvss3ScoringVector":"CVSS:3.1\/AV:N\/AC:H\/PR:N\/UI:N\/S:U\/C:N\/I:H\/A:N","cvss3BaseScore":"5.9","cwe":"CWE-295"}],"references":[],"publishedAt":"2023-10-06T23:10:01.903350Z","rpms":{"Rocky Linux 8":{"nvras":["curl-0:7.61.1-30.el8_8.3.aarch64.rpm","curl-0:7.61.1-30.el8_8.3.src.rpm","curl-debuginfo-0:7.61.1-30.el8_8.3.aarch64.rpm","curl-debugsource-0:7.61.1-30.el8_8.3.aarch64.rpm","libcurl-0:7.61.1-30.el8_8.3.aarch64.rpm","libcurl-debuginfo-0:7.61.1-30.el8_8.3.aarch64.rpm","libcurl-devel-0:7.61.1-30.el8_8.3.aarch64.rpm","libcurl-minimal-0:7.61.1-30.el8_8.3.aarch64.rpm","libcurl-minimal-debuginfo-0:7.61.1-30.el8_8.3.aarch64.rpm","curl-0:7.61.1-30.el8_8.3.x86_64.rpm","curl-debuginfo-0:7.61.1-30.el8_8.3.i686.rpm","curl-debuginfo-0:7.61.1-30.el8_8.3.x86_64.rpm","curl-debugsource-0:7.61.1-30.el8_8.3.i686.rpm","curl-debugsource-0:7.61.1-30.el8_8.3.x86_64.rpm","libcurl-0:7.61.1-30.el8_8.3.i686.rpm","libcurl-0:7.61.1-30.el8_8.3.x86_64.rpm","libcurl-debuginfo-0:7.61.1-30.el8_8.3.i686.rpm","libcurl-debuginfo-0:7.61.1-30.el8_8.3.x86_64.rpm","libcurl-devel-0:7.61.1-30.el8_8.3.i686.rpm","libcurl-devel-0:7.61.1-30.el8_8.3.x86_64.rpm","libcurl-minimal-0:7.61.1-30.el8_8.3.i686.rpm","libcurl-minimal-0:7.61.1-30.el8_8.3.x86_64.rpm","libcurl-minimal-debuginfo-0:7.61.1-30.el8_8.3.i686.rpm","libcurl-minimal-debuginfo-0:7.61.1-30.el8_8.3.x86_64.rpm"]}},"rebootSuggested":false,"buildReferences":[]}

Rocky Linux: RLSA-2023:4523 curl security update

October 6, 2023
An update is available for curl. This update affects Rocky Linux 8. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list

Summary

An update is available for curl. This update affects Rocky Linux 8. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE list


The curl packages provide the libcurl library and the curl utility for downloading files from servers using various protocols, including HTTP, FTP, and LDAP. Security Fix(es): * curl: GSS delegation too eager connection re-use (CVE-2023-27536) * curl: IDN wildcard match may lead to Improper Cerificate Validation (CVE-2023-28321) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.

RPMs

curl-0:7.61.1-30.el8_8.3.aarch64.rpm

curl-0:7.61.1-30.el8_8.3.src.rpm

curl-debuginfo-0:7.61.1-30.el8_8.3.aarch64.rpm

curl-debugsource-0:7.61.1-30.el8_8.3.aarch64.rpm

libcurl-0:7.61.1-30.el8_8.3.aarch64.rpm

libcurl-debuginfo-0:7.61.1-30.el8_8.3.aarch64.rpm

libcurl-devel-0:7.61.1-30.el8_8.3.aarch64.rpm

libcurl-minimal-0:7.61.1-30.el8_8.3.aarch64.rpm

libcurl-minimal-debuginfo-0:7.61.1-30.el8_8.3.aarch64.rpm

curl-0:7.61.1-30.el8_8.3.x86_64.rpm

curl-debuginfo-0:7.61.1-30.el8_8.3.i686.rpm

curl-debuginfo-0:7.61.1-30.el8_8.3.x86_64.rpm

curl-debugsource-0:7.61.1-30.el8_8.3.i686.rpm

curl-debugsource-0:7.61.1-30.el8_8.3.x86_64.rpm

libcurl-0:7.61.1-30.el8_8.3.i686.rpm

libcurl-0:7.61.1-30.el8_8.3.x86_64.rpm

libcurl-debuginfo-0:7.61.1-30.el8_8.3.i686.rpm

libcurl-debuginfo-0:7.61.1-30.el8_8.3.x86_64.rpm

libcurl-devel-0:7.61.1-30.el8_8.3.i686.rpm

libcurl-devel-0:7.61.1-30.el8_8.3.x86_64.rpm

libcurl-minimal-0:7.61.1-30.el8_8.3.i686.rpm

libcurl-minimal-0:7.61.1-30.el8_8.3.x86_64.rpm

libcurl-minimal-debuginfo-0:7.61.1-30.el8_8.3.i686.rpm

libcurl-minimal-debuginfo-0:7.61.1-30.el8_8.3.x86_64.rpm

References

No References

CVEs

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-27536

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2023-28321

Severity
Name: RLSA-2023:4523
Affected Products: Rocky Linux 8

Fixes

https://bugzilla.redhat.com/show_bug.cgi?id=2179092

https://bugzilla.redhat.com/show_bug.cgi?id=2196786


Related News

News

Powered By

Footer Logo

Linux Security - Your source for Top Linux News, Advisories, HowTo's and Feature Release.

Powered By

Footer Logo