Rocky Linux: RLSA-2021:3063 rust-toolset | LinuxSecurity.com
\{'type': 'Security', 'shortCode': 'RL', 'name': 'RLSA-2021:3063', 'synopsis': 'Moderate: rust-toolset:rhel8 security, bug fix, and enhancement update', 'severity': 'Moderate', 'topic': 'An update for the rust-toolset:rhel8 module is now available for Rocky Linux 8.\nRocky Linux Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.', 'description': 'Rust Toolset provides the Rust programming language compiler rustc, the cargo build tool and dependency manager, and required libraries.\nThe following packages have been upgraded to a later upstream version: rust (1.52.1). (BZ#1953002)\nFor more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section.\nFor information on usage, see Using Rust Toolset linked in the References section.', 'solution': None, 'affectedProducts': ['Rocky Linux 8'], 'fixes': ['1949194', '1949198', '1949204', '1949207', '1949211', '1950396', '1950398'], 'cves': ['Red Hat:::https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2020-36323.json:::CVE-2020-36323', 'Red Hat:::https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-28875.json:::CVE-2021-28875', 'Red Hat:::https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-28876.json:::CVE-2021-28876', 'Red Hat:::https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-28877.json:::CVE-2021-28877', 'Red Hat:::https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-28878.json:::CVE-2021-28878', 'Red Hat:::https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-28879.json:::CVE-2021-28879', 'Red Hat:::https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-31162.json:::CVE-2021-31162'], 'references': [], 'publishedAt': '2021-08-12T21:08:36.575890Z', 'rpms': ['cargo-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'cargo-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm', 'cargo-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'cargo-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm', 'cargo-doc-1.52.1-1.module+el8.4.0+641+ca238f88.noarch.rpm', 'clippy-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'clippy-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm', 'clippy-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'clippy-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm', 'rls-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'rls-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm', 'rls-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'rls-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm', 'rust-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'rust-1.52.1-1.module+el8.4.0+641+ca238f88.src.rpm', 'rust-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm', 'rust-analysis-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'rust-analysis-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm', 'rust-debugger-common-1.52.1-1.module+el8.4.0+641+ca238f88.noarch.rpm', 'rust-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'rust-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm', 'rust-debugsource-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'rust-debugsource-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm', 'rust-doc-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'rust-doc-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm', 'rustfmt-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'rustfmt-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm', 'rustfmt-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'rustfmt-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm', 'rust-gdb-1.52.1-1.module+el8.4.0+641+ca238f88.noarch.rpm', 'rust-lldb-1.52.1-1.module+el8.4.0+641+ca238f88.noarch.rpm', 'rust-src-1.52.1-1.module+el8.4.0+641+ca238f88.noarch.rpm', 'rust-std-static-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'rust-std-static-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm', 'rust-toolset-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm', 'rust-toolset-1.52.1-1.module+el8.4.0+641+ca238f88.src.rpm', 'rust-toolset-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm']}\

Rocky Linux: RLSA-2021:3063 rust-toolset

September 2, 2022
An update for the rust-toolset:rhel8 module is now available for Rocky Linux 8

Summary

An update for the rust-toolset:rhel8 module is now available for Rocky Linux 8. Rocky Linux Product Security has rated this update as having a security impact of Moderate. A Common Vulnerability Scoring System (CVSS) base score, which gives a detailed severity rating, is available for each vulnerability from the CVE link(s) in the References section.


Rust Toolset provides the Rust programming language compiler rustc, the cargo build tool and dependency manager, and required libraries. The following packages have been upgraded to a later upstream version: rust (1.52.1). (BZ#1953002) For more details about the security issue(s), including the impact, a CVSS score, acknowledgments, and other related information, refer to the CVE page(s) listed in the References section. For information on usage, see Using Rust Toolset linked in the References section.

RPMs

cargo-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
cargo-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm
cargo-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
cargo-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm
cargo-doc-1.52.1-1.module+el8.4.0+641+ca238f88.noarch.rpm
clippy-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
clippy-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm
clippy-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
clippy-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm
rls-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
rls-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm
rls-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
rls-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm
rust-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
rust-1.52.1-1.module+el8.4.0+641+ca238f88.src.rpm
rust-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm
rust-analysis-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
rust-analysis-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm
rust-debugger-common-1.52.1-1.module+el8.4.0+641+ca238f88.noarch.rpm
rust-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
rust-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm
rust-debugsource-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
rust-debugsource-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm
rust-doc-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
rust-doc-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm
rustfmt-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
rustfmt-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm
rustfmt-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
rustfmt-debuginfo-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm
rust-gdb-1.52.1-1.module+el8.4.0+641+ca238f88.noarch.rpm
rust-lldb-1.52.1-1.module+el8.4.0+641+ca238f88.noarch.rpm
rust-src-1.52.1-1.module+el8.4.0+641+ca238f88.noarch.rpm
rust-std-static-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
rust-std-static-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm
rust-toolset-1.52.1-1.module+el8.4.0+641+ca238f88.aarch64.rpm
rust-toolset-1.52.1-1.module+el8.4.0+641+ca238f88.src.rpm
rust-toolset-1.52.1-1.module+el8.4.0+641+ca238f88.x86_64.rpm

References

Severity
Name: RLSA-2021:3063
Affected Products: Rocky Linux 8

Fixes

https://bugzilla.redhat.com/show_bug.cgi?id=1949194

https://bugzilla.redhat.com/show_bug.cgi?id=1949198

https://bugzilla.redhat.com/show_bug.cgi?id=1949204

https://bugzilla.redhat.com/show_bug.cgi?id=1949207

https://bugzilla.redhat.com/show_bug.cgi?id=1949211

https://bugzilla.redhat.com/show_bug.cgi?id=1950396

https://bugzilla.redhat.com/show_bug.cgi?id=1950398

CVES

https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2020-36323.json

https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-28875.json

https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-28876.json

https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-28877.json

https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-28878.json

https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-28879.json

https://access.redhat.com/hydra/rest/securitydata/cve/CVE-2021-31162.json

We use cookies to provide and improve our services. By using our site, you consent to our Cookie Policy.