Discover Government News


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

[slackware-security]  wpa_supplicant (SSA:2024-059-01)

New wpa_supplicant packages are available for Slackware 15.0 and -current to
fix a security issue.


Here are the details from the Slackware 15.0 ChangeLog:
+--------------------------+
patches/packages/wpa_supplicant-2.10-i586-2_slack15.0.txz:  Rebuilt.
  Patched the implementation of PEAP in wpa_supplicant to prevent an
  authentication bypass. For a successful attack, wpa_supplicant must be
  configured to not verify the network's TLS certificate during Phase 1
  authentication, and an eap_peap_decrypt vulnerability can then be abused
  to skip Phase 2 authentication. The attack vector is sending an EAP-TLV
  Success packet instead of starting Phase 2. This allows an adversary to
  impersonate Enterprise Wi-Fi networks.
  For more information, see:
    https://www.cve.org/CVERecord?id=CVE-2023-52160
  (* Security fix *)
+--------------------------+


Where to find the new packages:
+-----------------------------+

Thanks to the friendly folks at the OSU Open Source Lab
(http://osuosl.org) for donating FTP and rsync hosting
to the Slackware project!  :-)

Also see the "Get Slack" section on http://slackware.com for
additional mirror sites near you.

Updated package for Slackware 15.0:
ftp://ftp.slackware.com/pub/slackware/slackware-15.0/patches/packages/wpa_supplicant-2.10-i586-2_slack15.0.txz

Updated package for Slackware x86_64 15.0:
ftp://ftp.slackware.com/pub/slackware/slackware64-15.0/patches/packages/wpa_supplicant-2.10-x86_64-2_slack15.0.txz

Updated package for Slackware -current:
ftp://ftp.slackware.com/pub/slackware/slackware-current/slackware/n/wpa_supplicant-2.10-i586-3.txz

Updated package for Slackware x86_64 -current:
ftp://ftp.slackware.com/pub/slackware/slackware64-current/slackware64/n/wpa_supplicant-2.10-x86_64-3.txz


MD5 signatures:
+-------------+

Slackware 15.0 package:
2be83120eeae199735756d3ecfc9afd8  wpa_supplicant-2.10-i586-2_slack15.0.txz

Slackware x86_64 15.0 package:
2bcea46d6ae7cd861208fe92f08e44ce  wpa_supplicant-2.10-x86_64-2_slack15.0.txz

Slackware -current package:
d44e7e706bc44d6c2978e97bdf6299d3  n/wpa_supplicant-2.10-i586-3.txz

Slackware x86_64 -current package:
5bb12ec9109ef4dbb58b4a0276ccbcfa  n/wpa_supplicant-2.10-x86_64-3.txz


Installation instructions:
+------------------------+

Upgrade the package as root:
# upgradepkg wpa_supplicant-2.10-i586-2_slack15.0.txz


+-----+

Slackware: 2024-059-01: wpa_supplicant Security Update

February 28, 2024
New wpa_supplicant packages are available for Slackware 15.0 and -current to fix a security issue

Summary

Here are the details from the Slackware 15.0 ChangeLog: patches/packages/wpa_supplicant-2.10-i586-2_slack15.0.txz: Rebuilt. Patched the implementation of PEAP in wpa_supplicant to prevent an authentication bypass. For a successful attack, wpa_supplicant must be configured to not verify the network's TLS certificate during Phase 1 authentication, and an eap_peap_decrypt vulnerability can then be abused to skip Phase 2 authentication. The attack vector is sending an EAP-TLV Success packet instead of starting Phase 2. This allows an adversary to impersonate Enterprise Wi-Fi networks. For more information, see: https://www.cve.org/CVERecord?id=CVE-2023-52160 (* Security fix *)

Where Find New Packages

Thanks to the friendly folks at the OSU Open Source Lab (http://osuosl.org) for donating FTP and rsync hosting to the Slackware project! :-)
Also see the "Get Slack" section on http://slackware.com for additional mirror sites near you.
Updated package for Slackware 15.0: ftp://ftp.slackware.com/pub/slackware/slackware-15.0/patches/packages/wpa_supplicant-2.10-i586-2_slack15.0.txz
Updated package for Slackware x86_64 15.0: ftp://ftp.slackware.com/pub/slackware/slackware64-15.0/patches/packages/wpa_supplicant-2.10-x86_64-2_slack15.0.txz
Updated package for Slackware -current: ftp://ftp.slackware.com/pub/slackware/slackware-current/slackware/n/wpa_supplicant-2.10-i586-3.txz
Updated package for Slackware x86_64 -current: ftp://ftp.slackware.com/pub/slackware/slackware64-current/slackware64/n/wpa_supplicant-2.10-x86_64-3.txz

MD5 Signatures

Slackware 15.0 package: 2be83120eeae199735756d3ecfc9afd8 wpa_supplicant-2.10-i586-2_slack15.0.txz
Slackware x86_64 15.0 package: 2bcea46d6ae7cd861208fe92f08e44ce wpa_supplicant-2.10-x86_64-2_slack15.0.txz
Slackware -current package: d44e7e706bc44d6c2978e97bdf6299d3 n/wpa_supplicant-2.10-i586-3.txz
Slackware x86_64 -current package: 5bb12ec9109ef4dbb58b4a0276ccbcfa n/wpa_supplicant-2.10-x86_64-3.txz

Severity
[slackware-security] wpa_supplicant (SSA:2024-059-01)
New wpa_supplicant packages are available for Slackware 15.0 and -current to fix a security issue.

Installation Instructions

Installation instructions: Upgrade the package as root: # upgradepkg wpa_supplicant-2.10-i586-2_slack15.0.txz

Related News