SUSE Security Update: Security update for xorg-x11-server
______________________________________________________________________________

Announcement ID:    SUSE-SU-2020:3582-1
Rating:             important
References:         #1174908 #1177596 
Cross-References:   CVE-2020-14360 CVE-2020-25712
Affected Products:
                    SUSE OpenStack Cloud Crowbar 9
                    SUSE OpenStack Cloud 9
                    SUSE Linux Enterprise Server for SAP 12-SP4
                    SUSE Linux Enterprise Server 12-SP4-LTSS
______________________________________________________________________________

   An update that fixes two vulnerabilities is now available.

Description:

   This update for xorg-x11-server fixes the following issues:

   - CVE-2020-25712: Fixed a heap-based buffer overflow which could have led
     to privilege escalation (bsc#1177596).
   - CVE-2020-14360: Fixed an out of bounds memory accesses on too short
     request which could lead to denial of service (bsc#1174908).


Patch Instructions:

   To install this SUSE Security Update use the SUSE recommended installation methods
   like YaST online_update or "zypper patch".

   Alternatively you can run the command listed for your product:

   - SUSE OpenStack Cloud Crowbar 9:

      zypper in -t patch SUSE-OpenStack-Cloud-Crowbar-9-2020-3582=1

   - SUSE OpenStack Cloud 9:

      zypper in -t patch SUSE-OpenStack-Cloud-9-2020-3582=1

   - SUSE Linux Enterprise Server for SAP 12-SP4:

      zypper in -t patch SUSE-SLE-SAP-12-SP4-2020-3582=1

   - SUSE Linux Enterprise Server 12-SP4-LTSS:

      zypper in -t patch SUSE-SLE-SERVER-12-SP4-LTSS-2020-3582=1



Package List:

   - SUSE OpenStack Cloud Crowbar 9 (x86_64):

      xorg-x11-server-1.19.6-4.19.1
      xorg-x11-server-debuginfo-1.19.6-4.19.1
      xorg-x11-server-debugsource-1.19.6-4.19.1
      xorg-x11-server-extra-1.19.6-4.19.1
      xorg-x11-server-extra-debuginfo-1.19.6-4.19.1

   - SUSE OpenStack Cloud 9 (x86_64):

      xorg-x11-server-1.19.6-4.19.1
      xorg-x11-server-debuginfo-1.19.6-4.19.1
      xorg-x11-server-debugsource-1.19.6-4.19.1
      xorg-x11-server-extra-1.19.6-4.19.1
      xorg-x11-server-extra-debuginfo-1.19.6-4.19.1

   - SUSE Linux Enterprise Server for SAP 12-SP4 (ppc64le x86_64):

      xorg-x11-server-1.19.6-4.19.1
      xorg-x11-server-debuginfo-1.19.6-4.19.1
      xorg-x11-server-debugsource-1.19.6-4.19.1
      xorg-x11-server-extra-1.19.6-4.19.1
      xorg-x11-server-extra-debuginfo-1.19.6-4.19.1

   - SUSE Linux Enterprise Server 12-SP4-LTSS (aarch64 ppc64le s390x x86_64):

      xorg-x11-server-1.19.6-4.19.1
      xorg-x11-server-debuginfo-1.19.6-4.19.1
      xorg-x11-server-debugsource-1.19.6-4.19.1
      xorg-x11-server-extra-1.19.6-4.19.1
      xorg-x11-server-extra-debuginfo-1.19.6-4.19.1


References:

   https://www.suse.com/security/cve/CVE-2020-14360.html
   https://www.suse.com/security/cve/CVE-2020-25712.html
   https://bugzilla.suse.com/1174908
   https://bugzilla.suse.com/1177596